Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Instrumented Method found in CPU sample but not in Methods


Hello everyone,

I am having a bit of trouble with an instrumented method. After putting a sensor on a method, and carrying out hot sensor placement, I am not able to see the method. I have carried out CPU sampling, and have found the method in question. Why is the method not appearing in the methods dashlet?

Any suggestions?


Dynatrace Organizer
Dynatrace Organizer

Hi Jose,

Have you checked under Agents Overview -> Deployed sensor, that your sensor has actually been deployed? Could be a temporary problem with the HSP. Have you tried (if you can) restarting the application server?
Also having some info about this tier can be helpful 🙂


Hello Valerio,

I have checked and the sensor is in the Deployed Sensors area. The application server has not been restarted. I have carried out a hot sensor placement, since it is an Oracle JVM

Dynatrace Pro
Dynatrace Pro

HSP will only have an effect on newly instantiated classes. So if you are dealing with a singleton for example, a restart might still be required.

Hello @Kristof Renders,

Thanks for your response. Unfortunately, the method where the sensor was placed comes from a class that is not a singleton. Any other suggestions?

sorry, but that's not correct.

HSP does not have anything to do with object instantiation. it's based simply on replacing the bytecode of methods inside a class. basically at a HSP the (potentially already JITted) bytecode of a method is invalidated so that at the next execution of that method it uses the new bytecode which is then interpreted or JITted again.

so the "worst" case could be that you have a method which runs forever, so that the HSP will never take effect. however, you really do not want to change the bytecode of a method while it is currently executed, of course! 😉

HTH, Christian

Hi Chris,

Thanks for clarifying this. This is how I was told a long time ago which now turns out to be wrong.

you cannot trust anyone, Kris 😉


Are you expecting to see this newly instrumented method within an existing purepath? If not then you could try setting Capture within the custom method sensor rule for this method from "active" to "active and start PurePath" -- this will cause the method to start a new purepath upon its invocation.

Hello @Srikar Mohan,

I am expecting the method to be visible in the methods dashlet, as the expected behavior. I have tried both setting the sensor rule to "active" and "active and start PurePath", but unfortunately, the method does not show in the methods dashlet, but I can see it be called using CPU sampling

Would it be possible to include a small session along with the cpu sample here or sent via email? Did you create the sensor from the cpu sample / from the class browser / manually defined it?

I manually defined it. I am attaching the session, as well as the CPU sampling session. The sensor in question is es.masmovil.mysimclient.PaymentClient, method topUp.


dtsrechargableengine.dts are some notes.

1) method topup is indeed instrumented, so that's good

2) please try making changes to capture setting at the custom sensor pack level as follows

3) set the sensor under agent group to active as follows

Let us know if this works. (may need a hsp?)


this is really a tricky one. everything looks correctly and the method also shows up as instrumented. you can try Srikar's suggestion, but it _should_ actually make no difference (there's also no need for a HSP).

could you please take a look at the deployed sensors tab in the agents overview and search for this method. when you've found it, what does it say in the "Sensor" column?

also I'm curious: did you try an agent restart already?


Hello @Christian Schwarzbauer,

The sensor is in the deployed sensors tab of the agent overview. I have attached a screenshot.

The agent was restarted on friday afternoon. This morning, I am able to see the topUp method in the methods dashlet. What bothers me though, is the hot sensor placement did not work, when the JVM meets the requirements for the HSP.