Showing results for 
Show  only  | Search instead for 
Did you mean: 

Java 1.5 and AppMon 6.5



We have some customers still running Java 1.5 in Prod.

If we upgrade AppMon server from 6.x to 6.5 we will be loosing support for such old JVMs, however I can not force our customers to upgrade their Prod JVMs as you may undestand.

Now, can we keep previous agent versions running and monitoring Java 1.5, but reporting to AppMon server 6.5

We would have to disable Bootstrap though in order to prevent an automatic upgrade of the agents.

Is it possible?

Is it supported?

What if it does not work? For the next maintenance renewal where do we stand with such gaps?

Thanks in advance!



Hello Carlos,

As per release notes only the Java
Virtual Machine 1.4.2 & 5 support discontinued with the 6.5 version.

You also have a control to stop the automatically update agent to the latest version from the update.

If automatic Agent updates are enabled the bootstrap Agent will be provided with the latest native Agent version available on the Collector. On the contrary, if the option is disabled the Collector requests the bootstrap Agents to use the same native Agent version as used last time.



Dynatrace Champion
Dynatrace Champion

Carlos, Part of the problem is that the customer is running a JVM which is no longer supported by the JVM vendor, but then they expect us to support such a configuration. This isn't possible for us to support, because if we find a problem that's due to the JVM vendor there's nothing we can do about it.

I suggest the customer consider the risk of continuing to run unsupported JVMs, and reconsider their JVM upgrade approach.

As for a 6.x agent reporting to an AppMon 6.5 server, that will likely work for a long time, but as stated, if a problem is found, this will create an awkward situation for your customer as Dynatrace will likely require them to upgrade to a supported architecture before we work on the problem which would mean upgrading their JVMs.



Dynatrace Pro
Dynatrace Pro

Hi Carlos,

as pointed out by Babar, see here on how to disable agent upgrades - but note the requirements listed there (an up-to-date bootstrapper).

Which old version is this specifically regarding to? Note that if the user is running 5.6 through 6.2 they are already running an unsupported (or soon unsupported) environment and support handling (for agents) will not change when upgrading.

In general we are stating compatibility with old versions: here. We are currently reviewing such situations, as well as technical approaches. I'll update this post if I have more info in the next weeks.

Best regards,



Thanks so much Babar, Thomas and Joe!

It really helps to review each possibility with you folks, I was not wrong then.

Customer is a large telco, and no one wants to upgrade Java in such environments usually, since everything is "up and running"...even if they are running unsupported software, but we must monitor that anyway.

Thanks a lot!