cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Java Script agent is not loaded and getting 404 on http://server:port/dynaTraceMonitor

Hi All ,

We have installed the web server agent and the configured a website on IIS server and loaded the dtagent.dll modules.

But when i launch the URL http://server:port/dynaTraceMonitor , i am getting 404 error.

I could see the dtagent_XXX.js is not loaded , what path we need to specify in the automatic configuration settings , it's asking for agent location.

Do we need to download the agent somewhere in the server ad provide the JS path ?

5 REPLIES 5

Hi Suganya, You trying to access UEM dynatrace monitor location right?

Pl. ensure below points:

1. License is installed and sensor is enabled (In app sensor by default the UEM sensor is disabled.)

2. You have defined the application mapping appropriately in respective system profile.

3. Check if your application domain location is set CORRECTLY in the agent location path in UEM tab. That means if your application root is something like https://app.mydomain.com/dir1/dir2/index.html then the agent location is https://app.mydomain.com/dir1/dir2/dynaTraceMonito... and not https://app.mydomain.com/dynaTraceMonitor.

Also, withUEM in AppMon 6.5, the bootstrap way of agent loading is deprecated. Instead use initcode approach as mentioned in the the documentation.

Let me know if you have any doubts. Regards,Rajesh.

developmenttool
Participant

@Rajesh S.

I could see the is insatlled and sensor is enabled , verifed application mapping too.

I am hitting my application in this URL http://server:port/

So i gave agent path as same and the monitor path as http//:server:port/dynaTraceMonitor

Since its not injected automatically , i hit the rest api and copied the script to my html.

Now i am able to see the script when give F12 , but still

http//:server:port/dynaTraceMonitor , is 404 and i am not able to dowload the agent too.

If i give the source link it's giving me 404 ..

Can you try accessing the URL iteratively from browser with inner paths like :

https://mydomain.com/dir/dynaTraceMonitor

https://mydomain.com/dir/dir2/dynaTraceMonitor

and so on. (These paths you see in OOTB URL BTs in Application Dashboard.)

Or you can make simple query to app team asking for the application context root dir.

(Also I hope you have not changed monitor name in Global UEM setting.)

When your monitor is correct you should get response something like in the snapshot:

Regards, Rajesh.

developmenttool
Participant

@Rajesh S.

Thank you for you help , seemingly there was an issue with the port in getting http post request.

I have modified the firewall settings and now we are able to get the response like you have given in the screen shot .

Could you mark my answer as accepted? 🙂