cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Jenkins Build failing to establish connection with dynaTrace restful interface

kiran_mylavarap
Newcomer

We are able to telnet from Jenkins build box to the dynaTrace server box on port 80. I have checked the services–>Management in server settings and Allow non SSL connections is set to Port 80. The issue is when I try to test the dynatrace connection from Jenkins after adding a post build action is throwing an error saying "Connection with dynaTrace RESTful interface could not be established".


9 REPLIES 9

kiran_mylavarap
Newcomer

CC:@Richard J.. Boyd . It is Jenkins plugin not Jenkins Build

wolfgang_gottes
Dynatrace Helper
Dynatrace Helper

This message can also mean that the username/password combination is wrong or the user is not permitted to use the REST interface. Could you try to verify that the password is correct and that the user has access to the rest api?

Thanks for the reply Wolfgang Gottesheim. I am able to launch the dynatrace in browser using same credentials.

There should be some additional log messages in the Jenkins log (or on the command line). Any chance you could take a look there?

The connection failure we are seeing before running the Jenkins build. So cannot view it in the logs.The error we are seeing when we click on the test dynaTrace connection. Attached is the screenshot.

Hi Kiran,

I was referring to the Jenkins log itself (not the build log), you can get there through Manage Jenkins - System Log - All Jenkins log. I'll improve the output in the next version...

kiran_mylavarap
Newcomer

Hi Wolfgang,

Thanks for giving me the right direction to find the issue. I found what was the problem. I was trying directly connect to default 'Test Automation' dashlet in dynaTrace. Because of which it was throwing that error. I have to save the default 'Test Automation' dashlet as a dashboard and tried connecting to the dashboard. The connection was successful.

Thanks!

Great to hear it worked out for you!

jgillotti
Guide

I'm having the same experience but with using Hudson....I did save the dashboard as its own name...any thoughts?