cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Modify agent port failed

carlos_chang
Inactive

Hi guys,

I've been trying to change agent connect to collector from port 9998 to 6698, but after I config agent and collector, I found agent still using port 9998 to connect collector from bootstrap log. Is there something I might miss to check?

4 REPLIES 4

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Did you restart the WS Primary agent process/service on that host where the WebServer agent is running?

carlos_chang
Inactive

Hi Joseph,

I only see Dynatrace 6.5 agent service, is this what you mean?

I already restart IIS service and agent service, but I got error 1053 "The service did not respond in a timely fashion"

BTW, I have to deploy agent and collector in different network sub-net due to user site restriction, does that related to this problem?

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Carlos, Perhaps we should verify what technology you are trying to monitor. I assumed you are trying to monitor a WebServer technology such as IIS on a Windows OS. This requires the Dynatrace WebServer Agent service to be running. If you don't see this service in the Services control panel, then the correct agent is not installed.

If this service is not running and won't start, then something else is wrong.

It's unclear to me which service is reporting the 1053 error.

Please confirm the first paragraph assumptions.

thanks

joe

Problem solved, it turn out my dtagent.ini got wrong config:(