cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

NGINX 1.10.3 on centos 7 - supported?

adam_gardner
Dynatrace Champion
Dynatrace Champion

Hi all,

The documentation suggests that any NGINX build above v.1.4.7 is supported but I can't see a binary explicitly stated on the supported binaries page.

If it's not supported on v6.5, will it be supported on v7.0?

3 REPLIES 3

alexander_zagor
Advisor

+1

dynT guys, please clarify this matter.

alexander_zagor
Advisor

Just another one attempt.

I downloaded and installed the following nginx rpms (stable release branch):

nginx-1.12.0-1.el7.ngx.x86_64 

nginx-debuginfo-1.12.0-1.el7.ngx.x86_64

from the official nginx repo:
https://nginx.org/packages/centos/7/x86_64/RPMS/

And this version works fine with:

CentOS Linux release 7.2.1511 (Core)

and AppMon version:

6.5.16.1011

c_schwarzbauer
Dynatrace Champion
Dynatrace Champion

as I wrote Adam already on the (additionally created) EAP ticket:

the nginx released builds for 1.10.3 on centos 7 are already supported in 6.5 by the OneAgent and also by the AppMon Agent if you just use the OneAgents offsets file.

in 7.0 they will be supported OOTB by both Agents.

however, as it's actually about a custom built binary in this case, the Agent has to generate the offsets manually. but then it's still supported.

Christian