cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

.Net events not showing / Instrumentation is not available

james_houston
Newcomer

Agent 6.5.13.1014
Bootstrap 6.5.0.1289

The Agents Overview page is showing 'Connected (Issue: Instrumentation is not available) on all .Net technology agents, and no data is available in the dashboard for analysis.

This had been working previously and I believe this *may* have started occurring since the windows servers were patched recently.

Can anyone offer a suggestion as to how this may be resolved?

The collector log errors as follows:

2018-07-12 10:25:42 WARNING [DotNetInstrumentor] Transformation of module 'mscorlib.dll' failed - java.lang.NullPointerException
2018-07-12 10:25:42 INFO [DotNetInstrumentor] java.lang.NullPointerException
at com.dynatrace.diagnostics.instrumentation.transformation.dotnet.expressions.v.<init>(SourceFile:18)
at com.dynatrace.diagnostics.instrumentation.transformation.dotnet.expressions.g.b(SourceFile:215)
at com.dynatrace.diagnostics.instrumentation.transformation.transformers.dotnet.j.h(SourceFile:135)
at com.dynatrace.diagnostics.instrumentation.transformation.transformers.dotnet.j.f(SourceFile:44)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.a(SourceFile:547)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.a(SourceFile:458)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.a(SourceFile:392)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.a(SourceFile:168)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.a(SourceFile:238)
at com.dynatrace.diagnostics.instrumentation.DotNetInstrumentation.instrumentModule(SourceFile:1198)
at com.dynatrace.diagnostics.collector.agentcenter.DotNetInstrumentor.requestReceiveIlCode(SourceFile:239)
at com.dynatrace.diagnostics.collector.protocol.agent.DotNetInstrumentationProtocol30.handleRequest(SourceFile:41)
at com.dynatrace.diagnostics.collector.agentcenter.Instrumentor.run(SourceFile:193)
at java.lang.Thread.run(Thread.java:745)


2018-07-12 10:25:42 WARNING [DotNetInstrumentor] Sent NOT OK to native agent



6 REPLIES 6

james_houston
Newcomer

Adding extra info... The agent log contains the following:

2018-07-11 21:16:40 [00000600] warning [native] module send failed: error code 500
2018-07-11 21:16:40 [00000600] info [native] Average transformation time for 1 classes/modules was 226ms - maximum set to 60000ms
2018-07-11 21:16:40 [00000600] warning [native] Profiler::ModuleLoadStarted(): Cannot process assembly c:\windows\microsoft.net\assembly\gac_64\mscorlib\v4.0_4.0.0.0__b77a5c561934e089\mscorlib.dll.
2018-07-11 21:16:40 [00000600] warning [native] Failed to transform assembly - stopping instrumentation
2018-07-11 21:16:49 [0000068c] info [native] License = license ok;
2018-07-11 21:17:20 [000008ac] warning [native] Unable to get Perfo

BabarQayyum
Leader

Hello James,

First of all try to restart the processes/application to connect back and then make sure the health of collector.

Regards,

Babar


Thanks for your reply.

This has been done. The issue persists for all of our servers which were recently patched.

For the web servers that are on a different patching schedule and haven't been patched yet we are able to see the metrics ok, so I assume the collector health is ok.

Connectivity to the connector from the agents is also quick.


Hello James,

Below are the supported version on the 6.5 platform.

What is your current version of .NET after the patched.

Regards,

Babar


james_houston
Newcomer

This is for .Net 4.7 and 4.7.1.

This wasn't upgraded as part of the patching, though I notice there were updates to the mscorlib.dll file as part of the security updates.

Which version of the agent is this table for? I notice for example in the release notes for Dynatrace AppMon 6.5.35 (if that is the same product), that there was a fix for a problem with .Net 4.7.1, so possibly a download of the latest 6.5.x agent may help?


Hello James,

I mentioned in my previous comments that the below table is for the 6.5 which is your current version.

You must have to migrate the AppMon to the minimum 7.0 release to support the 4.7 version and also the support already finished for the 6.5 so you will not get any feedback from the support.

Regards,

Babar