cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

No transaction flow and purepaths for system profile

rajanikanthanka
Inactive

Hello all,

I created a system profile for application and java agent. All agents are up and running but not seeing transaction flow and user action purepaths. I am including some screenshots here. Please help me what I am missing here.

agw-2.png

Thanks,

Rajanikanth

4 REPLIES 4

BabarQayyum
Leader

Hello Rajanikanth,

In the same dashboard check whether you have event counts, class load count etc...

Also check the following sensors are active and start PurePaths.

For the UEM, make sure that slide bar is on the right most.

Regards,

Babar

Hi Babar,

I see Event count and class load count from agents overview and they are showing values but total purepath count, cputime and execution time are zero.

I already enabled for servlets and User experience. Also enabled for Java web requests and java web services. Capturing is set to extreme right. All changes are done. But still I am not seeing any purepaths or transaction flow.

Do I need to restart my server and agents?

Hello Rajanikanth,

You can try once to restart the application to see the results. You can also share the logs after restarted the application.

If this is a non-web application or a proprietary Java Application, we may need to define your own PurePath starting points.

Check the following post to define the entry points:

https://answers.dynatrace.com/questions/108903/capturing-purepaths-in-non-web-applications.html

One more knowledge base with the screenshot examples to define the custom entry point in case of Auto Sensors are not picking up the PurePaths.

https://community.dynatrace.com/community/display/DTKB/How+to+define+entry+points

Regards,

Babar

Thanks Babar. We restarted agents and it worked. Now we are seeing transaction flow. and purepaths.

Thanks,

Rajanikanth