cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Node.js Agent cannot get updated automatically. Consider using the proper agent library.

anil_perera2
Helper

6.2.2.1016: The Agent cannot get updated automatically. Consider using the proper agent library.

I am seeing the above message on the detail page of my node.js agent.

I have installed node.js agent (6.2.2.1016) on Linux. This is the latest available for node.js

The Dynatrace server is running version 6.2.8.1019.

How do I get rid of this message?

2 REPLIES 2

srikar_mohan333
Inactive

Hi Anil, per my understanding, what you see on the agents overview is an informational message, from the doc "So far the Node.js Agent does not use the bootstrap / auto-update mechanism." If a new version of node.js agent were to be release for 6.2 then you will have to re-deploy the node.js agent and restart the instrument node.js. My customer is on v 6.3.4.1034 and node agent is on v 6.3.4.1032 and I see a message mentioned in your topic as well but the agent is working fine. So I guess its safe to say that the message can be considered informational.

anil_perera2
Helper

Thank You Srikar.