cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

OneAgent on AppMon -- changing communication port

hogan_kwan
Participant

Hi,

We have a AppMon 7.0 collector host with 5 collector instances on running on a range of port 9995 to 9999 for classic agents and port 8042 to 8044 for One Agents.

We are recently testing One Agent for NGINX but do not know how to change the comm port to 8042 or 8044 -- not seemed to be in dtwsagent.ini and also no mention in documentations.

Is this possible?

Thanks

5 REPLIES 5

BabarQayyum
Leader

Hello Hogan,

Edit communication port in <DT_HOME>/collector/conf/collector.config.xml and <DT_HOME>/server/conf/server.config.xml respectively.

Check the following link for the communication setup:

https://www.dynatrace.com/support/doc/appmon/installation/set-up-communication-connections/

Regards,

Babar

Hi Babar, thanks for your response. I don't find the link provides any steps/guide in changing the communication port for One agent.

We have collectors listening on 8042, 8043 and 8044. But I could not find a way to edit (on agents) to connect by port 8042 or 8044.

Perhaps this is not documented? Thanks

gbeltramelli1
Contributor

i have the same problem. Port 8043 timed out because there is no 8043 open in the collector side.

2018-10-22 19:37:05.584 UTC [4abd687f] warning [native] Bootstrapping failed: unable to perform request using https://x.x.x.x:8043/communication: Timeout was reached. Totaltime: 19.9432s, Uploadsize: 260b, Downloadsize: 0b, Connecttime: 0s
2018-10-22 19:37:05.584 UTC [4abd687f] info [native] Could not read persisted agent binary path:

The only port open is 9998.

<agentlistenaddressconfig>

<listenaddress agentaddress="" agentport="9998" />

</agentlistenaddressconfig>


Is it here where i should open the 8043 port?


Hello @Gaston B.

As per the documentation port # 8043 uses for the Node.js Agent connection.

You can change these ports in Settings > Dynatrace Server... > Services > General

Ensure that your firewall configuration allows communication between the components.

Regards,

Babar


gbeltramelli1
Contributor

Thank you very much @Babar Q !!!

I will try that !