cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PHP Custom Sensor configuration

roberto_ravo
Guide

Hi all,

I would a detailed monitor for one method but for now all my attempts don't works.

The method is the one selected on this image:

method.png

I've set the sensor rule like this:

method-conf.png

I can't understand what could be te mistake in the configuration.

Can someone help me?

Thanks in advantage,

Roberto

6 REPLIES 6

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

I might be wrong, but I think that the "F" in the icon to the left of the purepath indicates a function. Maybe you could try to create both, a "function" and a "method" rule and see if it helps?

roberto_ravo
Guide

Hello Peter,

I've tried this workaround but it didn't help, the situation is still the same.

I really don't know which could be the problem..

Best Regards,

Roberto

Have you tried without the parenteses () ?

Yes, but also with this modify is still not working.

Joe_Hoffman
Dynatrace Champion
Dynatrace Champion

Roberto,

I see a few things that might be wrong, however without full access to your profile it is hard to know exactly. So I'm providing several things to try.

1) You're specifying to capture Argument #1, however I can't tell if there really is an argument in this method. If there is not, then remove the "1" from the "Capture Arguments" field.

2) You're specifying "Equals" as a match criteria for the class definition. Are you sure this is the full classname? Try "Contains" pattern match.

3) You're specifying "End" as a match criteria for the method. Try "equals" or "Contains".

Hope that helps.

joe

roberto_ravo
Guide

Hi Joseph,

thanks for the reply. I've found the mistake in my configuration: simply the PHP path was wrong. I've spent a lot of time by finding the correct one since my collegue was unable to tell me a defined one.

Thanks to all!

Roberto