cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PWH migration error while connecting PWH after Dynatrace upgrade to 6.5 to 7.0

mayana_s_khan
Inactive

Hi,

We are upgraded to 6.5 to 7.0 on the same server. After upgration we are not able to connect to PWH.

Test connection is successful, but the connection is not happening. Please find the attach screenshots.

Regards,

Mayana Khantest-result.jpgconnection.jpg

12 REPLIES 12

Babar_Qayyum
Leader

Hello Mayana,

It takes sometime to create new schema on the first connect so you should wait without intrupting the process.

Secondly open the server and repository logs to know more in case there is any situation.

Regards,

Babar

@Babar Q.

Its about 20-30 min still it not connected. In repository log we have below logs.

Version 7.0.0.2469 built Tue May 30 13:59:01 CEST 2017
+ Platform: Linux 3.10.0-229.el7.x86_64, amd64 64bit
+ vm: Java HotSpot(TM) 64-Bit Server VM 1.8.0_121, Oracle Corporation, mixed mode
+ Timezone: Central European Time
+ Sizing Category: xLarge
+ Memory Category: xLarge96
+ Detected CPU: logical CPU cores: 48
+ Available memory: 257,835 MB physical memory
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9623
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] found duplicate conf measure for id=6585, duplicate id=9634
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9634
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] found duplicate conf measure for id=6585, duplicate id=9664
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9664
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] found duplicate conf measure for id=6585, duplicate id=9676
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9676
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] found duplicate conf measure for id=6585, duplicate id=9726
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9726
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] found duplicate conf measure for id=6585, duplicate id=9728
2018-02-17 03:05:20 INFO [V7_0_0_8__UpdateConfIds] could not find conf measure in dynamic measure tabe for conf id = 9728

new.png

Hello Mayana,

Nothing is meaningful in the repository logs. Check the server logs and also let me know the the DB version meanwhile support comes back with the solution.

Regards,

Babar

DB version in Oracle 12C

We have below logs related to performance warehouse!

2018-02-17 02:09:13 INFO [com.dynatrace.diagnostics.core.realtime.analyzers.el] Set dynamic measure cache size for JMX/PMI/Windows Performance measures to 10000
2018-02-17 02:09:17 WARNING [Server] There are pending performance warehouse migrations. Connecting the Performance Warehouse will execute the pending migrations.
2018-02-17 02:09:18 INFO [DynaTraceSSLSocketFactory] Removed all TLS cipher suites containig GCM for performance reasons
2018-02-17 02:09:18 INFO [DynaTraceSSLSocketFactory] Removed all TLS cipher suites containig GCM for performance reasons
2018-02-17 02:11:13 INFO [ServerAccessController] Connect of performance warehouse requested by client, from: mayana.s.khan@jmpdc

Hello Mayana,

In the migration guide, apply update to new AppMon step is before connecting to the performance warehouse as @Joseph M. H. pointed out.

Did you apply the latest update before connecting to the performance warehouse?

Regards,

Babar

No we not applied earlier. Now we have applied the 7.0.17* update to the server and trying to connect. Till now the same screen creating/migration ..

Hello Mayana,

At this stage just wait for few minutes because before yesterday I already did a migration and found that it takes sometime to complete this task so don’t panic and stop the process.

Regards,

Babar

Ok..If it is not connected then will go for rollback to 6.5. the old version will connect to PWH or not?

Regards,

Mayana Khan

Finally its connected...Thanks for you support 🙂

@Babar Q.

@Joseph M. H.

Regards,

Mayana Khan

Hello Mayana,

Congratulations 🙂

Now complete the remaining tasks.

Regards,

Babar

Support ticket SUPDT-42515created for the same..
We are struck in the middle of activity. If we rollback it will connect to old version 6.5?

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Mayana, It appears that you're not running the latest upgrade. I suggest you download and install 7.0.17 and see if that resolves the issue.