Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Performance Warehouse not creating Schema

We have connected to our database but we have been unable to create a schema. In our logs we have seen the following errors:

java.sql.SQLException: There is already an object named 'schema_version' in the database.

Solved this by dropping the existing table.

Found non-empty schema[SCOTTRADEQF\dynatracesvc] without metadata table! Use baseline() or set baselineOnMigrate to true to initialize the metadata table

Solved this by starting over with a new db shell.

Unable to determine schema for the metadata table. Set a default schema for the connection or specify one using the schemas property

Is there a requirement we may be missing here? We are running version 6.3.




Dynatrace Pro
Dynatrace Pro

Did you create the database with a "case insensitive" collation? That's a requirement. I've seen your first error message in the situation where it was created "case sensitive" instead.

Dynatrace Leader
Dynatrace Leader

I would also be good to verify you're using a supported version of a database. Which database and what version?


Hi Antony,

From the error message I can see that you are using Windows Domain authentication on your SQL server and the instance name is in combination with the domain name. This brings us to the main problem, the backslash between domain name and instance name (as seen in the error message: "schema[SCOTTRADEQF\dynatracesvc]") . This backslash is not handled correctly by our JDBC driver. So, that's the problem, where we do not have a solution at the moment - we are working on it.

But we have a workaround:

  1. Disconnect the PWH in the client
  2. Drop the 'schema_version' table in the 'SCOTTRADEQF\dynatracesvc' schema
  3. Create a schema 'dynatracesvc1' (or any other name) on the database (and grant table create and access right to the user of 'SCOTTRADEQF\dynatracesvc')

  4. In the folder 'DT_HOME/server/conf/', create a file named ''. The file must contain the following line:

    (or the different schema name, you have set in step 3)

  5. Connect the PWH again

If everything done correctly, it should work now. If not, please create a support ticket, referring to this blog entry

Best regards,