cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PostgreSQL as PWH on Linux

ksk_natsume
Inactive

Hi, This is Ryotaro

I want to use the PostgreSQL as PWH on RHEL7.
however, I couldn't connect from Dynatrace Client.

I installed PostgreSQL, and created DB.
I changed the "pg_hba.conf" and "postgresql.conf", and stopped firewall too though.

The error message as follow:
check connection to database server failed: Connection to XX.XX.XX.XX:5432 refused.

Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections. could you tell me about is there any notes on setting up PostgreSQL on linux?

Sorry for asking about PostgreSQL problem though.

Bestregards

Ryotaro

1 REPLY 1

Joe_Hoffman
Dynatrace Champion
Dynatrace Champion

Ryotaro, I'm not sure what modifications you made to the .conf files, but here's some notes I use when configuring PostgreSQl on Linux as a PW. These might be for an older version of PostGreSQl so I'm not sure they are still valid. Hope it helps.

joe


1.PGsql needs to be told to allow connections from
the dTServer, even if localhost

a.Edit DATA_LOCATION/pgsql/data/pg_hba.conf

i.On
Redhat family: DATA_LOCATION=/var/lib/pgsql/<version>

ii.On
Ubuntu family: /etc/postgresql/<version>/

b. “listen_addresses
= ‘*’ (remove comment and change “localhost’ to “*”)

c.modify/add a line to the bottom of the file
“host all all <ipaddress>/32
trust”

d.Change existing lines so METHOD is ‘trust’.

e.Don’t forget to reload postgresql (/etc/init.d/postgresql reload)