Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem in showing JDBC connection pool in JBoss Application


Dear community/support,

I've encountered a problem where information about jdbc connection pool is not showing up in database dashlet. Kindly provide advice or guide to reveal the connection pool information. Besides, It is a Hikari connection pool and the information is needed for analysis purposes due to database issues. The screenshot and session files is attached.

Session file : -



Hi Elton,

Hikari is not a supported connection pool. This is why you are not seeing the connection usage information. The agents will still capture the SQL calls but cannot retrieve information such as pool usage. We normally advice people to go down the custom JMX measure way (i.e. the properties are available in MBeans). I have successfully done this with another customer.

The only down side is that you will have to chart the connection usage on a custom dashboard.

To create a custom JMX measure, go to your profile/measure/create measure/ search for custom JMX. Click on browse metrics, select the relevant agent and find the correct property in the Mbean tree.



Hi Flo,

If I'm not mistaken, this requires JMX Mbean sensor to be enabled. After the sensors have been instrumented, I did tried to create measure for metrics such as maxPoolSize, minPoolSize, connectionURL, etc.. However, during the process of creation, I tested the metrics and it returns "Application server returned no value". Kindly advice on the scenario above.

Thank you.




I have the problem with showing connection pool size and usage. In my case hikari is used in tomcat. Unfortunately I don't see in JMX measure anything about connection pool. Instrumenting methods from hikari code also is useless because they aren't executed during requests. Any idea? 🙂



Please see HikariCP JMX instructions as the MBeans are not enabled by default. From there you can get these values by selecting in the JMX browser in AppMon. I've also thrown together an early Dynatrace plugin

Thank you for pointing this out. I will ask proper Administrator to turn it on 🙂