cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Problem with ms sql plugin is getting null

markus_leiman
Inactive

Hi, i have try to understand what is going wrong why i cannot get any plugin specific data. I am getting only null's when running plugin see picture below. I have appmon 7.0 on premise.

my db user has credentials to read these metrics and is belonging to "Performance Monitor Users group". DB agents is working fine but i need more detailed data and therefore this plugin is really important to get run properly. Any thoughts? 🙂


4 REPLIES 4

Mike_L
Dynatrace Pro
Dynatrace Pro

Can you add the logs written on the collector where the plugin is run? Possibly after increasing the log level (you can find that if you double click on the plugin on the screen were you added the plugin).


Hi @Michael L. i found one of collectors logs that says com.dynatrace.diagnostics.plugin.SQLPerfPluginMonitor.0.0.log:
2018-09-11 15:07:02 WARNING [PerformanceMonitor@New SQL Server Monitor_1] failed to retrieve value from: MSSQL$PWSQLPROD\PROD:SQL Statistics, SQL Compilations/sec, null: Unable to get Value. Please check if the host is reachable and the requested Performance Counter is available. Detailed error message: Unable to access the desired computer or service. Check the permissions and authentication of the log service or the interactive user session against those on the computer or service being monitored. (System error code: 0xC0000BDB)

https://docs.microsoft.com/en-us/windows/desktop/perfctrs/pdh-error-codes says that 0xC0000BDB (PDH_ACCESS_DENIED) Unable to access the desired computer or service. Check the permissions and authentication of the log service or the interactive user session against those on the computer or service being monitored.

This is giving quite clear message that i must have some connection issue since permission are working locally?


markus_leiman
Inactive

After trying to run process with another user i was ending to get this error message: 2018-09-12 15:04:09 WARNING [PerformanceMonitor@New SQL Server Monitor_0] failed to retrieve value from: SQLServer:Locks, Average Wait Time (ms), _Total: Unable to get Value. Please check if the host is reachable and the requested Performance Counter is available. Detailed error message: The returned data is valid.
(System error code: 0x0) "This is just one of the values that still shows NULL". Any idea where to go next?


markus_leiman
Inactive

GOOD NEWS, problem solved. I must say according to existing documentation it was not "the most easy" task to solve but finally we did it. See pictures below:

this picture is from server plugin properties and instance name is "the suffix" not "the full" name.

Also "the suffix" need to be added in "monitor" just like in plugin. When we got both right we started to get metrics 🙂