cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Removed Dashlet error.

yamini_dubey
Organizer

report-error.jpgPFA the screenshot of the error I am getting. I tried increasing the number of rows in the table for the report, but issue still remains. @Babar Q. anonymous user

8 REPLIES 8

Babar_Qayyum
Leader

Hello Yamini,

You can adjust the limit from client side and also from the server for the permanent effect to change the settings of maxTableRows.

The locally installed client uses the file dtclient.ini, dynaTrace/dynaTrace <version>/dtclient.ini

-Dcom.dynatrace.diagnostics.reporting.maxTableRows=10000

To do this adjust the file which is usually located at <dynaTrace Installation>\dtserver.ini

-Dcom.dynatrace.diagnostics.reporting.maxTableRows=10000

Regards,

Baba

Thanks @Babar Q.

So any changes that I make regarding this on server, could that have performance issues at server end?

Thanks and Regards.

@Babar Q.

My dtclient.ini file looks like this-

# WARNING:
# Manual changes in this file, except changes that are related to memory allocation, may cause severe problems and system instability.
# Apply manual changes only if you have explicit instructions from dynaTrace Support.
-basedir
client
-vmargs
-Xmx768M
-Djava.library.path=plugins
-Dosgi.checkConfiguration=true
-Dosgi.bundles.defaultStartLevel=4
-Declipse.registry.nulltoken=true
-Dosgi.instance.area=@user.home/.dynaTrace/dynaTrace 6.3/
-Dosgi.configuration.area=@user.home/.dynaTrace/dynaTrace 6.3/client/osgi
-Declipse.product=com.dynatrace.diagnostics.client.productId
-Dosgi.splashPath=platform:/base/plugins/com.dynatrace.diagnostics.client.branding, platform:/base/plugins/com.dynatrace.diagnostics.client.branding.jar
-Dosgi.bundles=org.eclipse.equinox.common@2:start, org.eclipse.core.jobs@2:start, org.eclipse.equinox.registry@2:start, org.eclipse.core.runtime@2:start, org.eclipse.update.configurator@3:start, org.eclipse.equinox.app@start, org.eclipse.equinox.event@start, org.eclipse.equinox.ds@start, org.eclipse.equinox.preferences@start, org.eclipse.core.contenttype@start
-Dorg.osgi.framework.language=en
-Dosgi.framework.extensions=com.dynatrace.diagnostics.bootstrap.hook
-Dosgi.nl=en_US
-Dnashorn.compiler.splitter.threshold=2147483647
-Deof=eof

Should i just go ahead and add the command line to this as new line or is it done some other way?

Also is there any other way apart from this to do this or we need to make configurational changes in client or server?

Babar_Qayyum
Leader

Hello Yamini,

Dynatrace limits the report size so the Dynatrace Server or Dynatrace Client is not affected by very large reports. Adjust the settings in client and server.

Add the setting to the file directly after -vmargs , not at the end. Client and server should be restarted to take effect.

You must also adjust the soft limit in the dashboard or dashlet because the default limit of 100 rows still applies, even if you raise the hard limit correctly.

Regards,

Babar

@Babar Q. Thanks that helps 🙂

PS: Congratulations for the award at Perform 2017!!

@Yamini D. Thank You 🙂

Hi, urgent here. I have confiured the maxTableRows to be 10000 last round, now I need to increase it to 20000.

But after I change the value in the ini file and restart the servers, still in the excel file it told me dashlet removed because limit of 10000 is hit.

The ini file of course is configured with 20000, but it seems like somehow it ignored/didn't read the line at all.

Any idea how to get this work? I have try to stop and then start the service (instead of simply restart), still no luck.

And in case you wonder, yeah, I didn't forget to raise the soft limit of the dashboard/dashlet before exported out as xlxs.

Hello @Wai Keat C.

Below are the troubleshooting steps as you already done with the basic settings.

  • After the setting is applied and the server or client is restarted, you should see the following line in the logfile, after the first report is triggered:

    • INFO [ServerReportManager] Using non-default limit of table rows per report: '20000'
  • If the line is not there, verify that the config-files are adjusted correctly and that the server and client are restarted to activate the new settings.
    • dtclient.ini files must only be located under C:\Users. If they are located in places like C:\Program Files (x86)\dynaTrace\dynaTrace <version>, remove them.

Review the below link for all the basic requirements and the troubleshooting steps.

https://www.dynatrace.com/support/doc/appmon/application-monitoring/reporting/reporting-limits/

Regards,

Babar