cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

SCOM Plugin for Dynatrace 7.0 installed on Linux

mohammed_zahriy
Newcomer

Is this plugin going to be update so that it will work on dynatrace servers that are running Linux?

4 REPLIES 4

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

What part doesn't work for Linux based AppMon Servers?

mohammed_zahriy
Newcomer

When I looked at the description of the plugin to download I saw this message. specifying that it is only for windows.

Known Problems

The action plugin executes dynaTrace.SCOM.exe on the dynaTrace server. dynaTrace.SCOM.exe is a .NET Console Application. Therefore this Plugin only works on dynaTrace servers that run on windows with an installed version of the .NET 2.0 Framework.

Joe_Hoffman
Dynatrace Leader
Dynatrace Leader

Ah, yes, that limitation. I forgot about that.

The plugin is open source and anyone is free to improve upon it as necessary. However I"m not familiar with the feasibility of generating SCOM events from Linux. If it's possible, then it would be relatively easy to do such from the Plugin's Java source.

jhanson
Newcomer

Anyone modify this plugin or know of a successful workaround for sending alerts to SCOM from a Linux Dynatrace server?

@Shane K. @Anthony P.