cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Test Automation: Right click on Test/Browser purepath doesn't works after a while

n_sonnier
Participant

Hi,

We use dynaTrace with Jenkins/Selenium on Browser agent/Apache Agent/JBoss Agent.

Results of Tests are displayed in Test Automation Dashlet. and Tests are saved in Stored Sessions.

After few days the right click on a test to display Browser Purepath do not work anymore but access from System Profile or from Session works.

Is there a way to keep this link alive... It's realy usefull.

Best regards,

Nicolas.

10 REPLIES 10

n_sonnier
Participant

Just a precision:

After some hours , the right click on a test to display Browser Purepath from the test automation dashlet do not work anymore but access  from the recorded Session works.

There is no link between the test automation dashlet and the data stored in the matching recorded sessions.

Regards,

Nicolas. 

wolfgang_gottes
Dynatrace Helper
Dynatrace Helper

Hi Nicolas,

Are you using continuous session storage and export sessions, or are you starting/stopping session recording?

Best regards,
Wolfgang

m_ronteix
Newcomer

Hi Wolfgang,

I'm working with Nicolas. We do not use continuous storage, we start and stop session recording for each Jenkins build.

Regards,
Marion

Thanks! We're working on reproducing the issue locally to see what happens here

 

Hi,

First of all, I'm sorry for the late response.

I'm working on reproducing the problem, but so far the drilldown links are working in my environment. Let me ask you a few additional questions:

  1. How many tests sessions do you record per day?
  2. Do the links also stop working if there's no new session added?
  3. Does that happen only for UI-driven tests?
  4. How do you manage recorded sessions? Are they deleted after some time?
  5. Do you make drilldowns from the main table with test list, or from the dots displayed on the metric charts?

Thank you for your answers.

Best regards,
Wiktor Bachnik

Hi,

I managed to recreate the problem today. The links that were working yesterday now fail to display any data. I will keep you updated.

Best regards,
Wiktor Bachnik

m_ronteix
Newcomer

Hi Wiktor,

OK, thanks. Do you still need answers to your previous questions ?

Marion

Currently not, thanks. We're trying to track the cause with our test scenario.

Best regards,
Wiktor Bachnik

I entered an issue in our internal tracking system for that problem (JLT-123643).

Best regards,
Wiktor Bachnik

m_ronteix
Newcomer

Thanks for your help.

Regards,
Marion