cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Top Process Monitoring Plugin - unable to execute monitor

andrew22
Inactive

We're trying to use the Top Process Monitoring plugin located here: Top Process Monitoring Plugin

The issue we're having is the monitor is reporting:

Problem collecting processInfo: java.lang.RuntimeException: [frws1725] Connecting to remote server failed with the following error message
: WinRM cannot process the request. The following error occured while using Ker
beros authentication: The network path was not found.
Possible causes are:
-The user name or password specified are invalid.
-Kerberos is used when no authentication method and no user name are specifie
d.
-Kerberos accepts domain user names, but not local user names.
-The Service Principal Name (SPN) for the remote computer name and port does
not exist.
-The client and remote computers are in different domains and there is no tru
st between the two domains.
After checking for the above issues, try the following:
-Check the Event Viewer for events related to authentication.
-Change the authentication method; add the destination computer to the WinRM
TrustedHosts configuration setting or use HTTPS transport.
Note that computers in


I've made sure that powershell's remote execution is enabled too, and it appears the authentication details in the monitor settings are only used for SSH with Linux. Has anyone had success with this plugin with Dynatrace 6.1?

11 REPLIES 11

paul_kuit2
Inactive

Hi Andrew,

The ssh-username and ssh-password properties are used only for Linux SSH connection authentication.

Powershell permissions are managed by the underlying Windows OS. Please execute the following command manually in a dos prompt from the Collector machine, logged on with the same user as the collector process to verify if powershell is enabled correctly:

powershell invoke-command -computer localhost "{get-process | fl ProcessName, ID, Handles, NPM, PM, WS, VM, CPU}"
(* substitute localhost with your destination host)
In case of powershell remote invoke-command difficulties please consult Microsoft Technet:
Regards,
Paul

gayathri_reddyv
Inactive

Hi Paul,

I am also having the same issue as Andrew. I have created the monitor specifically for Windows. I have logged in to the collector machine and manually exceuted the below command in a dos prompt and got the result. Also verified that the powershell´s remote execution is enabled. But still I get the error.

I have left the ssh-username and ssh-password properties blank as it is only for windows. Where do I specify the credentials for windows server?

 

Regards,

Gayathri

 

graeme_william1
Inactive

Gayathri,

Did you log in to the collector system as the user that the collector runs with?  Normally this is Local Service – this is the user that needs permission to run Powershell and execute 'get-process'.

-- Graeme

Hi Graeme,

How do I login to the collector system from the monitor, when I create the monitor it just asks for SSH username and password but nothing for windows. Please guide me.

Thanks,

Gayathri

Gayathri, Graeme is suggesting that you should log into the box you are trying to connect to with the credentials needed to ensure that the user you are connecting with CAN do what you are trying without the collector. 

HTH,

Kyle

Kyle,

I am able to login to the windows machine with the credentials and execute the powershell command. But my question here is, where do I specify the credentials in the Top plugin monitor for windows.

Regards,

Gayathri

 

I'm not quite sure I'm sure Graeme would know more

graeme_william1
Inactive

Gayathri,

You don't (and can't) specify the credentials for the plug-in running on a Collector running on a Windows system.  The Collector simply uses the credentials which it was started with.

So the question is, what credentials is the Collector using?  You can tell by going to the Services control panel (i.e., under Administrative Tools -> Services), locating the Collector and looking at the "Log On As" column.  It's almost certainly "Local Service".  These are the credentials we're talking about – not the credentials you use to log on to the system as a user.

Could you verify that the Collector is running under "Local Service", please?

-- Graeme

 

gayathri_reddyv
Inactive

Graeme.

I just verified and the collector is running under "Local Service".

Regards,

Gayathri

graeme_william1
Inactive

Gayathri,

The easiest way to proceed might be to change the user the Collector runs under, since you already have a user that you know has the right permissions.

In the Services control panel, right-click on the Collector and select Properties.  Go to the Log On tab, make sure that the 'This Account' radio button is selected, then click on Browse and Advanced.  Locate the user you logged in as when you ran the permissions checks and select it.  Add the password on the Log On tab and hit OK.  Restart the service.

I'm assuming that this is an administrator account of some sort that will have access to the Dynatrace install directory.  If not, you might change the permissions on the Dynatrace install directory so that Everyone has full control.

Then try running the plug-in again.

-- Graeme

gayathri_reddyv
Inactive

Thank you Graeme. I changed the user on the Log On tab and it started working.