cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Transaction flow not showing on Monitoring but works fine on Transaction Flow Dashlet

sebastian_kryst
DynaMight Leader
DynaMight Leader

Hello,

I have strange situation. On Test environment everything works fine, but on production we have also connected agents. PurePaths are collecting fine since yesterday. I can see transaction flow on Transaction Flow dashlet without any problems. Everything is working fine. But when I click Monitoring with selected correct System Profile I see info:

No transactions for selected timeframe.

I've tried to change for shorter and longer periods but no luck. What can be the problem?

11 REPLIES 11

pahofmann
DynaMight Leader
DynaMight Leader

Have you checked that you have the same timeframe and systemprofile selected in both dashboard when comparing?

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

Yes, it is the same

Okay, then you should try what Florent suggested. As he said, all the Monitoring Dashboards come from the cache, maybe there is a problem with the cache.

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

florent_duchate
Dynatrace Pro
Dynatrace Pro

Hi

from the monitoring button, the data comes from a cache but with the transaction flow dashlet from the cockpit it doesn't.

It must be an issue with the cached version. Could you try to bounce your server and see if it works again?

Regards

Flo

I've tried what you suggested but it doesn't help. I don't have any messages with problems about DT Server.

The fun thing is that when we started connect agents yesterday it was working. When I came to client today and all agents are connected the problem shows up.

dave_mauney
Dynatrace Champion
Dynatrace Champion

I would also verify that your Performance Warehouse is connected by charting any measure for 24 hours. If only an hour shows up, it is not working...

Ok you are right, there is some problem with Performance Werhouse. It is connectec correctly but metrics are only for one hour back. So there must be some problem with permissions. I've asked network guys for veryfication.

You may be able to disconnect/test connection/connect and get it working.

I've tried. On dynatrace server logs there are no errors about Performance Werehouse. System is working fine. Metrics are only on one hour back like you said. My Monitoring transaction flow looks like this.

Could you add a screenshot of you PWH settings, or the repository log?

Dynatrace Certified Master, AppMon Certified Master - Dynatrace Partner - 360Performance.net

sebastian_kryst
DynaMight Leader
DynaMight Leader

Ok I've found solution. I've forgot to add domain config for PF to dtfrontendserver.ini. It was only on dtserver.ini so it has been connected but doesn't work at all. No everything is fine.