cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Trying to get AppMon Apache agent working

paulseward
Inactive

Hi,

I am trying to get the Apache agent for One (AppMon) working and keep seeing the folllowing in the logs:

URL https://localhost:8043/communication not working (Failed to connect to localhost port 8043: Connection refused)
Bootstrapping via https://localhost:8043/communication

Does anyone know where I can change localhost to point to my collector?

Paul

2 REPLIES 2

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello Paul,

Review the below link for the default communication layer used by AppMon components, and provides access to information about configuring the settings needed to deploy AppMon into a networked environment.

https://www.dynatrace.com/support/doc/appmon/insta...

8043: The Node.js Agent uses this connection.

These ports are used for the Node.js Agent (Linux only) to connect the Collector to the Server. There is no UI to change them. Edit communication port in <DT_HOME>/collector/conf/collector.config.xml and <DT_HOME>/server/conf/server.config.xml respectively.

Ensure that your firewall configuration allows communication between the components.

Regards,

Babar

Babar,

Thanks, i think I have just realized this server has node.js on, which I don't need to monitor. There must be another reason the Apache agent is not loading. PHP is working and showing in the Agent Overview.

The confusion is that this log is from a web server, not a collector, I guess it must be relaying the message.

Paul