cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

UEM and Microsoft's Dynamics CRM

gilgi
Advisor

Hi All, 

 

we're trying to install UEM on Dynamics CRM. Using auto injection we see the script being injected correctly. However, even though GET commands to the dynatrace signal are received perfectly by the server, the POST signal (reporting the data) automatically extended with default.aspx (the default site page), hence not being caught.

Does any one have any experience with Dynamics CRM and UEM ?

Gil.

9 REPLIES 9

wilson_lai
Dynatrace Organizer
Dynatrace Organizer

We have a Dynamic CRM POC today and observed the same situation.

This seems to happenning because ISAPI Filter on IIS is redirecting the request to default.aspx,
if there was no extension to the request. You need to remove or change ISAPI Filter on IIS.

Howver, the ciustomer did not want to make change of the setting and we found a web folder does not have the translation (they created for some customized pages), so we set the dynaTraceMonitor collection path under this folder.

Regards

andreas_grabner
Dynatrace Leader
Dynatrace Leader

Thats great insight - thanks for sharing. It is a best practice to use a different path for /dynatracemonitor to avoid any problems like blocked HTTP Requests of certain types on the root url

Andi

Please aware that the username is not transfer within the CRM (the user use single sign on, and can see user name in main page).

We did CPU sampling around main page and add most name related sensors (include those getters) in order to get a meaning visit tag, but seems nothing suitable as of today.

If anybody knows the internal of Dynamic CRM, please give us some insight.

Regards

MichaelFerguson
Dynatrace Helper
Dynatrace Helper

Wilson,

I know you said they are using SingleSignOn,   but did you look at the CRM AppPool server variables.   If not try adding the server variable AUTH_USER to your CRMAppPool ASP.NET sensor properties.   This worked for Jerry L and I at our current CRM POC.  

We are now running into the the ISAPI filter issue.   We will be talking to the customer later today about this.

Thanks,

Mike

Hello Michael,

i have a question about AUTH_USER, our client is also using CRM, i have added the server variable to ASP.NET sensor group and this seems to work, what is the best way now to create a measure so i can use this in my UEM configuration to correlate users to visits ?

Thanks
Jody

jerry_lobenstei
Dynatrace Advisor
Dynatrace Advisor

Creating a dummy folder under the site called CRMDynaTrace and posting the monitoring signal back to the folder did resolve the 404 issues we had at this customer site.

Monitoring Request Path   /CRMDynaTrace

See attachment*

Jerry

 

 

andreas_knorre
Dynatrace Helper
Dynatrace Helper

Hi,

Creating
another site in IIS for our JavaScript agent is sometimes cumbersome or not even
possible as this might require another SSL certificate for this site.

Here
another solution: CRM configures the IIS so that it always adds default.aspx to
all requests. This ends in an http 404 error when the JavaScript agent is
trying to send back data.

I tried to
disable "Default Documents" in IIS Manager and to reorder the modules
to put the "dynaTrace IIS WebServer agent" modules to the top of the list
of modules… - all with no success.

The
solution:

Enter the following
Monitoring request path in Dynatrace Client -> System Profile -> User
Experience -> Default Application -> JavaScript Agent -> Monitoring
request path: https://<ServerName>/default.aspx

The JavaScrip
Agent then sends back the monitoring data to:

https://<ServerName>/default.aspx/dynaTraceMonitor

Looks strange
but it works! IIS is accepting this with http 200 code.

Best
Regards,
Andreas

elliot_ashton
Newcomer

Hi,

The default.aspx/dynaTraceMonitor option worked for me.

sgreenshield
Inactive

Thanks for this information ..... the default.aspx/dynaTraceMonitor option sorted the UEM issue for me across a number of CRM instances we are monitoring.