cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

UEM sends an http dtagent js resourse request rather than an https. Why?

dave_deleo
Inactive

Can someone tell me what dictates whether the uem dtagent js resource request will be https or http. We thought the originating page dictated that. However, we are finding that the originating page is https but when we look at the developer tool the resouce request is http://.../dtagent...

Does anybody have any ideas why this might be occuring. Is there something within UEM config that we can control this with?

Thanks,

David


3 REPLIES 3

Babar_Qayyum
Leader

Hello David,

Add the Secure attribute to the AppMon session cookie. Useful for web sites that employ the HTTPS protocol for secure communications, this setting marks the AppMon session cookie dtCookie with the W3C-standard Secure attribute. This attribute instructs the web browser to only send the cookie over a secure connection.

Have a look on the below link.

https://www.dynatrace.com/support/doc/appmon/admin...

Regards,

Babar


dominik_punz
Dynatrace Pro
Dynatrace Pro

By default the beacon URL is relative to the endpoint that served the HTML page. If it was served via HTTPS it would go back the same way. Since in you case this does not happen I assume that you manually edited the endpoint in your UEM application configuration. You might have inserted "http" instead of "https" right there.


dave_deleo
Inactive

Thanks Babar and Dominik! It was verified that we used the relative path so http had not been inserted. Great thought though! Babar this is some great information that we can investigate using. Thank you both!

David