cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

URL Monitor v 6.1 is not working -- Dynatrace v 6.1

I have created URL Monitor with following settings:

Monitor Tab

Schedule Tab

Run scheduled for every 5 min

Measures Tab:

HostReachable --> Lower Severe = 0

Following is Retrieved measurements:

HostReachable: 0.0 ( I don't know why it's value is 0 even given URL is working fine ) , Last Run Result: incomplete , Result Status: success

Then I created incident to send email notification in case threshold exceeded

Evaluation Timeframe: 5 min , Incident Severity: Severe

Conditions: Measure: Hostreachable , Threshold: Severe , Aggregation: min

In Action tab I entered my email id.

I didn't get any email notification so I assumed it's working fine..

But again to check if it's really configured properly I change Path value to /en/Solutionsfsafsfsdfdsf in URL monitor. Now I should get email notification because this URL is not correct.

But still I didn't get any email notification. Am I missing something.

Following I found in Logs:
2016-10-06 22:37:50 INFO [UrlMonitor@Solutions URL Monitor_0] Previous message was repeated 3 times.
2016-10-06 22:37:50 INFO [UrlMonitor@Solutions URL Monitor_0] Executing method: GET, URI: http://stgwebsite.abc.us:80/en/Solutionsadcd

Thanks

3 REPLIES 3

peter_karlhuber
Dynatrace Pro
Dynatrace Pro

Hi Sankhar,

as per the documentation here "0.0" for "HostReachable" means that the monitor didn't get a response in the 60 second timeout (i.e. it didn't work). The URI that you've quoted from the log is probably not the correct one (http://stgwebsite.abc.us:80/en/Solutionsadcd), do you have log entries where it tried with the one that you've configured in your screenshot?

As a corollary, you should configure your incident so that you get an email when the value is 0.

Best regards,

Peter

david_c_johnson
Advisor

make sure you close /confirm the previous incidents, as it doesn't sound like it was ever reacheable for you. (do this on the incidents dashlet)

make sure that the url is reachable from your collector, not your desktop. make sure your host entry in the infrastructure configuration is setup to just have the hostname "stgwebsite.abc.us" don't prefix with http. you can even hardcode in the ip address into the definition if you're unsure, although I don't suggest it. (I'm not saying you have it misconfigured, but some people might just paste in the whole thing when setting the entry up).

I spoke to IT team and found that these URLs are not reachable from collector machine which run the monitor plugin and now they are working on to grant access for URLs.

Further just to check I added www.google.com Hosts and scheduled to run for every 10 minutes but didn't get any measure's value looks like even google is also no reachable from collector machine.

Measures: