cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

URL monitor 6.1 SSL handshake failed error in DT 6.1

Hi Team,
URL monitor 6.1 was working fine till date but today I'm getting following exception:

SSL handshake failed, this may be caused by an incorrect certificate. Check 'Disable certificate validation' to override this.
Exception message: peer not authenticated

Even I checked the Disable Certification validation check-box but issue doesn't get resolved.

I do have Dynatrace Client 6.1. Please suggest where should I check now.

Thanks

13 REPLIES 13

harshal_pujari
Dynatrace Pro
Dynatrace Pro

Hi Sankhar,

Have you checked the URL Monitor logs under System Information dashlet-->Support information-Log Files->com.dynatrace.diagnostics.plugins.URLPluginMonitor.0.0.log?

Or just search in the system information dashlet for "com.dynatrace.diagnostics.plugins.URLPluginMonitor.0.0.log"

Also, what version of the URL Plugin monitor are you using? You can find that by clicking on the Settings menu-->Server-->Plugins

Also, it seems like you are on Dynatrace 6.1; I would strongly recommend to upgrade to the latest version.

Hope this helps.

Regards,

Harshal.

Hi Harshal,
I got following logs:

2016-11-22 16:01:22 INFO [UrlMonitor@Prod URL Monitor_0] Previous message was repeated 14 times.
2016-11-22 16:01:22 INFO [UrlMonitor@Prod URL Monitor_0] Executing method: GET, URI: https+ignorecert://www.mywebsite.com:443/

URL monitor( 6.1.0.7880 ) and DT version( 6.1.0.7880 ) already mentioned in the title of this post. Actually it was working fine till yesterday but don't know suddenly what happened.

Thanks

Hi Harshal,

Any idea on this

Any update from your side on this? I know you posted this question on different pages and also different platforms,e .g: stackoverflow.

If this behavior changed from one day to the next it is probably not related to a dynatrace issue but more an issue with one of your certificates. As was mentioned earlier - you should definitely upgrade to a newer dynatrace version. 6.1 I believe is no longer officially supported

joshua_pavlica
Dynatrace Pro
Dynatrace Pro

@Andreas G: I am experiencing similar issues with the SSL Handshake Error, but I am running 6.5.0.

Some sites are running fine according to URL Monitors, but others on the same web servers are producing a "SSLHandshakeException: Remote host closed connection during handshake" message, with details of:

URL: http://rdulpnemo50:80/us/en/envision
Connection failed: DynaTraceHttpClientException: Exception was thrown while executing a HTTP request
Caused by: SSLHandshakeException: Remote host closed connection during handshake
SSL handshake failed, this may be caused by an incorrect certificate. Check 'Disable certificate validation' parameter to override this.

I have checked the "Disable Certificate Validation" parameter and I am still receiving this error.

harshal_pujari
Dynatrace Pro
Dynatrace Pro

joshua_pavlica
Dynatrace Pro
Dynatrace Pro

Harshal,

It was working before with the original configuration.

I have tried what you suggested and also with port 443 instead of 80. Same issue each time.

All of these monitors were configured the same way and run on the same web server hosts, but I'm getting mixed results: https://i.imgur.com/wAd5LqC.png

Still I'm getting the same issue. Actually my website is hosted in clustered environment so Load balancer is actually handling all incoming request for https://www.mywebsite.com domain and redirect to individual server( http://mywebsitehostserver1:80 and http://mywebsitehostserver2:80 ). As we know this problem is only with SSL so I have set up two URL monitor without SSL for website monitoring.

Did you end up getting the non-SSL monitors to work?

I am still having issues with SSL and without for these URL monitors.

I've tried different hostnames, different webserver IPs, different ports, and different selection options and am still receiving these errors for specific sites. Is this a webserver configuration issue on my end??
@Andreas G.

michael_k
Dynatrace Helper
Dynatrace Helper

The "disable certificate validation" option actually only allows to accept certificates with untrusted signatures (this wording has been improved in future versions).

There are other options which may cause the SSL connection to fail however. The typical reason is that the certificate is encrypted with an outdated cipher which has been disabled by Oracle in the Java JVM for security reasons. This can only be fixed by using an updated certificate on the site in question. The easiest way to check this is to simply navigate with the latest version of a popular web browser (e.g. Chrome or Firefox) to the URL in question, if the certificate has the mentioned issues the browser will also show a corresponding error.

If the connection with a browser works fine, please open a support case with an attached support archive and the certificate (can be exported via web browser when connected to the site) in question.


hope this helps,

Michael

I am able to access the websites fine with a normal browser, so I have followed your suggestion and downloaded the certificates/created a support archive and made a support ticket.

I will respond to this overall question thread with any results.

Thank you, Michael!

joshua_pavlica
Dynatrace Pro
Dynatrace Pro

Just got the URL Monitor to work again. Ticket details can be found here:

https://support.dynatrace.com/supportportal/browse...

To summarize it, there were two or more redirections happening with the URL I was targeting, so I had to focus on the ending URL (which is HTTPS), but configure it with normal HTTP Port 80 and the full URL.

Before I was HTTPS 443 with path of /us/en/home/. To get it working, I had to use HTTP 80 with the full https://website.com/us/en/home/endingURL as the path.

That fixed my issue, and I hope it works for you too!

keerti
Organizer

Hello,

I am using Dynatrace 6.3 and I am getting the same issue for a SOAP monitor using an HTTPS URL though the certificate validation is disabled. When I run the SOAP monitor manually, I am not getting the error. But every now and then, the monitor throws this error causing a "HostNotReachable" incident. We can't have false incidents happening in Prod. How can I resolve this issue?

Thanks,

Keerti