cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to login using Active Directory after upgrading AppMon from 7.0 to 7.1 - Failed to login user 'NNNN'

jhem
Advisor

After the upgrade, we can still use the default admin account. But we are unable to login using LDAP / Active Directory.

2018-08-24 19:52:26 UTC WARNING [PermissionManager] Authentication failed for user: jhem<br>2018-08-24 19:52:26 UTC WARNING [ClientSessionInitializer] Failed to login user 'jhem'

Any chance to increase log verbosity to discover what could be causing this? The LDAP configuration is the same, migrated the previous 7.0 installation. Connection tests work well, but we simply cannot login.

Quick upadate: I was able to find this question as a reference. But the suggested options in dtserver.ini did not make any difference.


4 REPLIES 4

Hi @Julio M.,

I am no expert but i am guessing this could be because of improper migration of data. As a part of the upgrade during the migration of data you would need to manually migrate a few config file like dtserver.ini, dtfrontendserver.ini, collector.ini etc. You would need to compare these files with your old configuration files (migration tool copies your old files into your new DTHome). Please make sure you have migrated these files properly and do not re-use the old file as using them can cause problems.

If that doesn't help, I would recommend opening a migration support ticket with Dynatrace. They are usually very quick and good to help with issue like this.

Thanks,

Rohith


jhem
Advisor

I reviewed *.ini files during migration, but never found anything that might be relevant to this. All customized options we had in the old *.ini were ported to the new one.

I'll try a support ticket if I can't find a way out of this.

Thank you!


Please keep us posted with your findings.


jhem
Advisor

With a support ticket, we were able to find the problem. Somehow, during migration, the user I was testing was quietly disabled for LDAP Authentication. It's a checkbox in the user configuration.

After re-enabling this checkbox, authentication worked again.