cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to start java agent using -agentpath on ibm jre 1.4

tim_white
Newcomer

Hi,

We are trying to use an AppMon 6.x agent against a WAS 5 application on AIX 5.3 using IBM JRE 1.4.

The errors we've had indicate that -agentpath is not valid (this is from 6.1):

The JVM option is invalid: -agentpath:/opt/dynatrace/was/dynatrace/agent/lib/libdtagent.so=name=MyAppName,server=MyAppServer:MyPort
[ Unrecognized option: -agentpath:/opt/dynatrace/was/dynatrace/agent/lib/libdtagent.so=name=MyAppName,server=MyAppServer:MyPort ]

I've had a browse around the Dynatrace site and not yet found answers.

Could someone point me at the 6.1 documentation

Is there an alternative to -agentpath that should be used with ibm jre 1.4

Are we looking at using a far earlier version of the Java Agent?

Cheers

Tim

7 REPLIES 7

I think JRE 1.4 is not supported. I am not sure though.

tim_white
Newcomer

Cheers Rajesh & Patrick.

I've had the jre version double checked and it's 1.4.2.11, so should be okay

We've tried

-Xrundtagent:/opt/dynatrace/was/dynatrace/agent/lib/libdtagent.so=name=MyAgentGroup,server=MyServer:MyPort

with and without the path to libdtagent.so and get the following error

No java stack
JVMCI158: Can't load "libdtagent.a", because load ENOENT on shared library(s)
JVMCI098: xmloadJVMHelperLib dtagent /opt/dynatrace/was/dynatrace/agent/lib/libdtagent.so=name=MyAgentGroup,server=MyServer:MyPort, failed
Could not create the Java virtual machine.

The path has been checked as has permissions.

Why libdtagent.a and not libdtagent.so ?

Would ENOENT be talking about the dtagent library or something within the JRE ?

I checked the Documentation of version 6.1, and the newest WAS version mentioned there is Version 6. The config String I supplied is generated by the client for WAS with JRE 1.4.2 on AIX, but maybe there has to be something different with WAS 5.

tim_white
Newcomer

Hi Patrick,

I noticed the 6.1 and above restriction in the wizard too. I guess I need to invoke support.

Thanks for your thoughts on this.

Tim

If you open a Ticket, it would be great if you post the outcome here for future reference if other people run into the same problem 🙂

Hi Patrick.

The answer seems to be the use of WAS 5 in our application stack (EOL 11 years ago!)
Whilst older versions of the Appmon agents supported AIX 5.3 & JRE 1.4.2, WAS 5 has never been supported.
WAS 5.1 was desupported at AppMon 5.6

The answer summary provided by Support was:

This environment can't be monitored with AppMon.
WAS 1.5 was never supported by any AppMon release.
AIX 5.3 is desupported since AppMon 6.2
Java 1.4 is desupported since AppMon 6.5

Tim

Thanks for posting you answer here!