cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

User Action take duration time much, what is a point the root cause. Mobile App/Apache/Java/Server/Network

natthapong
Newcomer

Hello, everyone

Please, somebody help
us to confirm or advise to fix this expectation be the root cause of problem. Our
customer has had UEM and business transactions User Action take duration time
much as Visit pic.


















We expect root cause of
issue have been happened between Mobile App and Threads of Apache be full usage
as Threads chart and Transaction flow pic.




The information above
make us think root cause happen from Threads of Apache be full usage, it makes
some process/action of Mobile App in queue for wait Threads/Worker have idle
because issue appear at the same duration time between User Action and Threads
of Apache be full usage.

If our expectation is
correct. We would like to somebody advise to turning Threads of Apache to
expand it and advise our customer because we tried to find an explanation on web
ref. http://httpd.apache.org/docs/2.4/mod/mpm_common.html#threadlim, it explain
MaxSpareThreads parameter have the default is 250 but we don’t sure that must change
this parameter because have many parameter related Threads of Apache.

Customer’s Apache parameter detail as pic below;



5 REPLIES 5

Babar_Qayyum
Leader

Hello Natthapong,

As per the shared screenshot 'Network' is the main reason of slow actions.

Did you ask the bandwidth utilization particularity for this mobile application?

Can you disable the bandwidth calculation on mobile browsers to isolate the issue?

Regards,

Babar

Thanks for your suggestion, we will check it with our customer about that.

Jussi_Nieminen
Dynatracer
Dynatracer

Hi Natthapong,

It looks like this Apache server is using the "prefork" MPM module, which means that it is actually using worker processes instead of worker threads. In this case the important configuration value is "MaxRequestWorkers", which seems to have been set to 250 in the configuration. Increasing this value will enable Apache to spawn more worker processes.

The large amount of network delay you are seeing is due to the fact that the requests are stuck in the listening socket's waiting queue while all Apache workers are busy; this does not mean that the bandwidth is not enough. Once Apache has enough worker processes to handle the load, the network contribution should become very small again.

Just for reference, a little explanation on the other values seen in the configuration under "IfModule mpm_prefork_module":

* StartServers: this is the initial amount of servers started by Apache when it boots. This should be close to the amount of Apache workers during standard load on your system so that Apache can handle the traffic right after startup.

* MinSpareServers: this is the amount of free (not busy) server processes that Apache tries to keep around. So if your traffic often has big spikes, you should keep more servers around ready to handle the spikes. It will create more overhead on the system though.

* MaxSpareServers: this is the maximum amount of those free worker processes. If more processes than this amount are not busy, Apache starts to kill the unnecessary workers.

* MaxConnectionsPerChild: this is the number of connections handled by a child process before it terminates and forces Apache to spawn a new worker. This is more of a workaround for buggy modules with memory leaks, and should not even be necessary in normal case.

Best,

Jussi

Thanks for your suggestion, we will discuss that with our customer.

Hi everyone, I’m Natthapong V.

Update issue, after advise our customer as our recommend but
advise of forums about Bandwidth calculation and MaxRequestWorkers of Apache @Babar Q. @Jussi N., customer
have been scheduling to process. Our customer added MaxSpareThreads parameter
more than 250 at last week but still have issue, user action take duration time
much as screenshot;

Visit of issue;

Transaction from User Action blue selected;

Time 12.31 Apache process many take Transaction response
time contribution%;

Time 12.31 Purepaths tree of Purepaths many take response
time;

Time 12.33 External service process many take Transaction
response time contribution%;

Apache process of purepaths at time 12.31 – 12.33, it’s normal,
thread is not full.

User Action Purepaths at time 12.31, Purepaths: *[com.techberry.icollection.service.ICollectionAndroidService]*
Client Family: Samsung Galaxy Tab S2 8.0, it take Transaction response time
contribution on Mobile App 100%

Above information, Is it possible that root cause may be
devices version of Samsung Galaxy Tab S2 8.0 because our customer only have sent
visit Client Family Samsung Galaxy Tab S2 8.0 on everytime.

If you have more any advise, please do not hesitate to reply me, Thank so much. #appmon 7.0