cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

Web Server Master Agent Can't Be Started Remotely Using Client after Upgrade from 6.5 to 7.0

waikeat_chan
DynaMight Pro
DynaMight Pro

Just asking this out of curiosity, I thought ever since version 6.5 and above the agent would has this capability?

I just upgraded both server and collector AppMon version 7, but in the agent overview when I right click, the 'restart agent' option is grey out.

I've tried restart both collector and server in any order. Still the same.

4 REPLIES 4

thomasK
Dynatrace Pro
Dynatrace Pro

Hi Wai,

this works for me. It also requires a certain agent version. Which version and bootstrap version does the agent in question have?

Best regards,

Thomas

waikeat_chan
DynaMight Pro
DynaMight Pro

Hi Thomas,

The agent version is 6.5, while the bootstrap version is 6.1.

Regards,

Wai Keat

From my findings:

To be able restart the webserver master agent, you need:

  • a bootstrap agent >= 6.2

for a host agent, you need:

  • a bootstrap agent >= 5.5

for a zRemoteAgent:

  • a normal agent >= 6.5

For any of these agents, you also need:

  • Permissions to restart agents
  • A client >= 6.2
  • The agent has to be bootstrapped in general
  • Must not be a subagent
  • Must be a classic agent

So in your specific case, you need to upgrade the bootstrap version.

Best regards,

Thomas

waikeat_chan
DynaMight Pro
DynaMight Pro

Hi Thomas,

Thanks for the clarification.