cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why are my agents no longer working on AIX after installing 7.0.10, 7.0.11, or 7.0.12?

Users on that are running outdated technology levels on AIX 7.1 that have already been end-of-life'd by IBM may face an issue after installing recent AppMon updates (7.0.10 to 7.0.12).

The following linker error is displayed when the agent dynamic library is being loaded:

DSO load failed __setjmp symbol was not found

Root cause: AIX system is outdated; starting with 7.0.10 the agent is expecting a newer
version of libc that comes with AIX 7.1 TL3 SP8/9
(7100-03-08-1642) onwards.

Solution:

- install the latest service IBM updates on your AIX system

- or use the controlled roll-out feature to exclude affected AIX systems from agent updates

R&D is currently investigating a compatibility enhancement to address this issue.

1 REPLY 1

Root cause: AIX system is outdated; starting with 7.0.10 the agent is expecting a newer
version of libc that comes with AIX 7.1 TL3 SP8/9
(7100-03-08-1642) onwards.

Solution:

- install the latest service IBM updates on your AIX system

- or use the controlled roll-out feature to exclude affected AIX systems from agent updates

R&D is currently investigating a compatibility enhancement to address this issue.