cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Why do Client uses a server certificate on port 8031?

Dear Dynatrace,

I wonder why AppMon Client uses a server certificate for communication on tcp 8031? It creates problems for "Open in Client" drill downs. Is it changeable?

Best regards,

Guntars

12 REPLIES 12

arihant_polavar
Dynatrace Pro
Dynatrace Pro

Hello Guntars,

What kind of problems are you facing with the drill downs?

You can change the Port used by the Client by going into Settings -> Dynatrace Client on your AppMon Client and clicking on the 'Services' tab. You will see the SSL and non-SSL ports (8031 and 8030 by default) for the REST Web Services.

BabarQayyum
Leader

Hello Guntars,

Are you sure about Port #? Is that 8021 or 8031?

Find the following link to setup the communication connections.

https://community.dynatrace.com/community/display/...

Regards,

Babar

Hello Ari and Babar,

This is a browser - client communication. You have to accept broken SSL communication because javascript in Web UI calls https://localhost:8031/rest/management/version.jso... but the client claims having my AppMon server certificate. 😞

Best regards,

Guntars

Hello Guntars,

I am wondering that I did not find the port number mentioned by you in the document and also in my client services because port # 8021 use for web interface for RESTful Server administration, to start the Webstart Client.

Regards,

Babar

Hi Babar, this is actually a client side setting so you'll find the ports 8030 and 8031 in the client settings as opposed to server settings under 'services'.

Thank you @James K.

Can you try using 8030 instead of 8031 and see if that makes a difference?

I have both ports enabled. How can you configure Web UI to use HTTP?

Ok, I think I understand what you are trying to do. You've got a PurePath on the WebUI and you want to drill down into the Client. I'm guessing its giving you a dialog box complaining about the Certificate and to use the WebStart Client? Do you also see a link to 'Accept SSL Connection'? If you click on that and add it as an exception, it will work for your browser.

For a more permanent fix though, I would look into Certificate Management and see if you can deploy a self-signed or a company certificate across the AppMon components.

I'm sorry for not so detailed description of the issue. But you've got it right, thank you.

That's exactly the point I've invested my time to get and deploy the company's certificate so that our users could feel good browsing the "safe" site. 🙂 Sure, I can accept a broken SSL communication but that session at least on Chrome will be marked as not safe anymore. And most of users are confused getting "Accept SSL .." and a browser suggests not to do that. 🙂

JamesKitson
Dynatrace Leader
Dynatrace Leader

Hi Guntars,

I just played around with it and the port it tries to use seems to be based on whether you're using https in the web interface. If you try to drill down from a page in https it will try to use SSL and port 8031, but if you are browsing plain http it will try to open on port 8030. I get that error as well when trying to use 8031, but 8030 opens fine for me.

EDIT: It also works for me if I use the "accept the SSL certificate option" -> accept the certificate in the new tab that opens up, then close the error popup in the first tab and try to open in the client again.

James

Hi James,

Thank you. It would be a good way out but our security team started to enforce us to use SSL. ;(

Best regards,

Guntars