cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ZRA1@W561 get "invalid instrumentationstate"

lars-erik_bergl
Newcomer

We set nobootstrap=false in the zosagent parms Everything looks good in the bootstrap and the zos logfiles.

dynaTrace z Remote Agent data channel connected
successfully, performing handsha

dynaTrace z Remote Agent client handshake
performed.

dynaTrace z Remote Agent data channel handshake
successful, version(6.5.4.1014).

dynaTrace z Remote Agent control channel connected
successfully, performing hand

dynaTrace z Remote Agent handshakes are complete,
all channels are fully operati

Registering SMO socket with FD=x000000000000000A.

Starting listeners.

Control client socket listener thread started

All listener threads are being started...

All listener threads have been started, waiting for
shutdown...

Checking to see if all listeners have started....

All listeners have started=true

zIIP-Enabled SMO Listener started

Waiting for listener to finish, from main for
zIIP-Enabled SMO Listener

zIIP SRB enabled with socketFD=0x000000000000000A

The zLocalAgent is connected to the dynatrace
server.

ace/v65/prod/log/dt_ZOS_MEPC_33555094.0.log

...but in CICS it takes 10 seconds Before he posts the following answer:

ZDTP017S zDC INIT Failed

Status:

CICS Applid..................
FOLCIPTP DT Version....... 6.5

CICS Jobname.................
CICPTP PLT PTF..........
00000000

TRUE Status..................
DISABLED Agent PTF........ 00166001

XPCREQ/C
Status.............. DISABLED zDC
Name......... MEPC

RMIIN/RMIOUT
Status.......... DISABLED Agent ID.........
00000000

No zDC
connection or Exits, no Ping.

What does "ZDTP017S zDC INIT Failed" mean? DTAX PING/ENA does not activate subagents.

zOS Agent shows up with "invalid instrumentationstate" in Agent Overview/Details.

Can't find errormsg in the documentation or in the forum.

We are on version 6.5.4.1014.

1 REPLY 1

mike_horwitz
Newcomer

Hi, It's hard to tell exactly from this log snippet, but I would verify the agent mapping for the zRemoteAgent.

Your best bet, however, is to open a support ticket.

thanks

Mike