cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

agent names with [1] inserted into name

thomas_eurick
Contributor

Hi all, I've noticed at times upon agent restarts sometime i will see the agents listed with a name that has a [ 1 ] inserted into the name (example: webapp[1]@servername: pid).

 

Does anyone have an idea on the why, how to avoid, and ramifications of this behavior?

11 REPLIES 11

brandon_combs22
Inactive

thomas_eurick
Contributor

 

Thanks, in my case though I do not have duplicate agent names so it's odd that after an agent restart the only instance of it came in as a indexed name. That is what has me curious.

richard_boyd22
Inactive

If the agent does not have enough time to de-register or go offline on the server, the server will give it the indexed name.  Short story is the restart was too quick and dynaTrace thought it saw two agents.

Hey Rick,

A follow up question on this: We had an unexpected restart of the JVM on Tuesday 10/8 and since then an application process is offline.

That application process has the same name as a different application process, but with the [ 1 ] at the end. I was assuming a restart of the JVM would resolve the issue.

We have daily restarts in the morning and I have verified that the JVM restarted today; however I still see the offline application process. Why would this be?

Thanks,

Harshal.

Hey Harshal, do you mean you still see the disconnected JVM on the Agent Overview?

If that is the case, with 5.5 the offline agents are automatically deleted after 3 days, so you will still see them listed for 3 days.

Hey David,

Thanks for the reply. The agents are connected, but the application process with  [ 1 ]is still offline. No disconnected agents in the agents overview. Also, we are at 5.0

Regards,

Harshal.

Whats the fix for this? It's unrealistic to leave the production JVM down till it de-registers.

Hi Clint,

You can disable this by turning off the -Dcom.dynatrace.diagnostics.collector.agentcenter.unique_agent_names_with_index flag (set it to false) on the dtserver.ini file.

More info here -> https://community.dynatrace.com/community/display/DOCDT65/Unique+Agent+Names+with+Index#UniqueAgentNameswithIndex-EnablingtheFeature

Thanks,

Ari

Thanks Ari. Is that the fix? Will it reconnect instantly using the same name?

Its not necessarily a 'fix'. Its simply disabling the feature. You will no longer see the indexes if you turn that off.

How to you merge the data? Or will there be a gap in data until the 1st agent name de-registers or merge between an agentx and an agentx[1]?