cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

appmon agent fail to install on WebSphere Message Broker on AIX

rkpichardo
Guide

we are trying to install the WebSphere Message Broker Agent on Linux AIX and it fails with the attached screen error.

we are following this guide:
https://community.dynatrace.com/community/display/DOCDT65/WebSphere+Message+Broker

are we missing something? its the installation agent corrupt? any help in this case?

9 REPLIES 9

david_c_johnson
Advisor

On *NIX, use java -jar packagename.jar. You are asked for the target directory, which defaults to your current one.

tyvm, now is installed!

bill_scheuernst
DynaMight
DynaMight

I am having difficulty installing a Java agent on an AIX box. This is for IIB/Message Broker. I am getting "Invalid argument given!" when attempting this command...

java
-jar dynatrace-agent-6.5.0.1289-unix.jar
-agentpath:/opt/IBM/mqsi/V10/dtagent65/agent/lib64/libdtagent.so=name=MBTEST1,server=sdt01

Is the "name" the agent name? Also, how can I view my current configuration? Seeing the current configuration might help with this endeavor.

Dynatrace Certified Professional

Reading the help file, I tried this...

java -agentpath:
/opt/IBM/mqsi/V10/dtagent65/agent/lib64/libdtagent.so=name=MBTEST1,server=sdt01
-jar dynatrace-agent-6.5.0.1289-unix.jar

Now getting...

JVMJ9TI001E Agent library could not be opened (The file access permissions do not allow the specified action.)
JVMJ9VM015W Initialization error for library j9jvmti27(-3): JVMJ9VM009E J9VMDllMain failed

Dynatrace Certified Professional

Hello Bill,

For the installation you just need to extract the agent with the following command:

java -jar dynatrace-agent-6.5.0.1289-unix.jar

You will be asked for the target directory, which defaults to your current one.

For the correct configuration, check the following link:

https://community.dynatrace.com/community/display/DOCDT65/WebSphere+Message+Broker#WebSphereMessageBroker-AIXandz/Linux

Regards,

Babar

Thanks. Btw, I already did your first step. What I'm really trying to do is configure the agent. I will check out the documentation.

Dynatrace Certified Professional

Hello Bill,

We also have an AIX and z/Linux in our environment. If you follow the docuement then there should not be any issue because only difference in between configuring the simple Java agent and message broker that you will have to configure the exit library (.lel file) which must be registered in the WebSphere Message Broker installation.

Regards,

Babar

Thanks for the info. A few questions and comments remain.

Setting DT_HOME environment variable?

Setting DT_AGENTNAME environment variable?

Where/how do you configure the exit library? I didn't see that when running the java installer. Is there a different agent for MB other than the AIX Java agent?

Dynatrace Certified Professional

There is no different Java installer.

DT_HOME is the path of your agent.

DT_AGENTNAME you can replace with the your broker name which is by default "WebSphere_MB".

You will have to create a file /change this information into the dtwsmbagent.sh

You can show the shared document link with the Middleware administrator and he will immunderstand that where he needs to do these changes.

There are two different libraries, one for version 6 and other for above so he will have to choose one accordingly.