cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

classic(None of the configured ports for HTTP-based communication are reachable from host

karthikayini_mu
Inactive

Hello All,

Connected new agent. It got connected successfully. Anyways it is showing the below msg in agent group.

Any issue ?

Thanks & regards

Karthikayini M


5 REPLIES 5

This is because agent connect as Classic one. Your configuration (by default for all new agent groups) is for Appmon agent. This is different technology, with less overhead on application, collector. It uses different communication technology (not TCP, HTTP Rest) on different ports. If you will open ports Dynatrace is asking about, after next restart agent will switch to Appmon Agent. But be aware that this needs also extra ports between collector and server open (if you are using external collector).

Sebastian


thi_hoai_linh_l
Newcomer

Hi Karthikayini, I'm facing on the same problem. Do you have solution for it? Thanks!


As I've answered on my previous answer:

this is default communication port between server and collector for appmong agent which uses rest interface.

And these are default ports used for communication between Appmon Agent and collector. This communicate states that non of those "Appmon to Collector" ports are open. Classic agent used different ports because of TCP connection. More info here:

https://www.dynatrace.com/support/doc/appmon/installation/set-up-communication-connections/

Sebastian


Hi Sebastian, thanks a lot for your reply! I've the same problem with the error:

Classic (None of the configured ports for HTTP-based communication on the Dynatrace server are reachable by the Dynatrace Collector with the name "dynaTrace Collector" from host "l-as327". AppMon uses HTTP-based communication which requires access to the ports: 8040, 8041. Please adapt your firewall setting accordingly.)

Do I understand correctly that I should unlock/open:

  • the ports 8040 and 8041 between the collector to dynatrace server
  • the port 8042 and 8043 between the application to Collector

Thanks!


Yes, if you didn’t change port settings default are like you have mentioned.

Sebastian