cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

dtang adapter startup failed on collector

ashutosh_singh1
Organizer

Dear Team,

I have installed DT collector 7.0 instance, after starting of service. It is showing below error:
2018-01-10 12:46:21 SEVERE [DtangAdapter] dtang adapter startup failed on collector dynatrace_dmz_collector112_backup:

com.dynatrace.diagnostics.collector.dtang.DtangAdapter start:62
java.net.BindException: Cannot assign requested address: bind
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:321)
at com.dynatrace.diagnostics.jetty.WebServerStarter.startServer(WebServerStarter.java:198)
at com.dynatrace.diagnostics.jetty.WebServerStarter.startServer(WebServerStarter.java:140)
at com.dynatrace.diagnostics.common.ruxitadapter.AbstractDtangCommunication.start(SourceFile:167)
at com.dynatrace.diagnostics.collector.dtang.DtangAdapter.start(SourceFile:59)
at com.dynatrace.diagnostics.collector.Collector.K(SourceFile:2789)
at com.dynatrace.diagnostics.collector.Collector.l(SourceFile:810)
at com.dynatrace.diagnostics.collector.Collector.b(SourceFile:201)
at com.dynatrace.diagnostics.collector.Collector$CollectorStartThread.run(SourceFile:568)

2018-01-10 12:46:21 INFO [Collector] Collector started.

Regards,
Ashutosh

3 REPLIES 3

Babar_Qayyum
Leader

Hello Ashutosh,

In the logs 'Cannot assign requested address' is mentioned also use the netstat command in case the collector listening port already in use from other process.

Did you read the complete collector logs for a bit more information?

Regards,

Babar

Hi Babar,

I have allotted different port to an collector instance and that is in listening state. There is no established connection with that port. I saw logs only I can able to find below error logs as well:

2018-01-10 13:08:00 WARNING [Collector] Could not open port 9997 on interface 'x.x.x.108' for collector communication! java.net.BindException: Cannot assign requested address: JVM_Bind
2018-01-10 13:08:01 WARNING [AgentListener] Specified binding address for Agent Listener not valid: x.x.x.108

I did telnet as well on that port was listening, Kindly let me know what will be possible solution for same.

Regards,
Ashutosh

Hello Ashutosh,

Are these collectors standalone or on the same AppMon server?

The problem is only with new created instance or also with the default one.

You did the Telnet from where to where and which port.

Regards,

Babar