Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

dynatrace RESTful web server failed to start du to a non-existing file in keystore


Dynatrace jetty server failed to start. Any one has any idea why dynatrace is looking for server.jks which doesn't exist. Log as below.

2017-03-14 12:46:13 WARNING [JettyLogger] failed SslSocketConnector@ /opt/dynatrace/dynatrace-6.1.0/server/conf/server.jks (No such file or directory)
2017-03-14 12:46:13 WARNING [JettyLogger] failed Server@10f97eb7: /opt/dynatrace/dynatrace-6.1.0/server/conf/server.jks (No such file or directory)
2017-03-14 12:46:13 WARNING [ServerServiceTrackerCustomizer] Unable to launch HTTP Server.: com.dynatrace.diagnostics.webservices.ServerServiceTrackerCustomizer startJetty:185 : /opt/dynatrace/dynatrace-6.1.0/server/conf/server.jks (No such file or directory)




Dynatrace Guru
Dynatrace Guru

The first thing I have to tell you is that Dyntrace AppMon 6.1 is no longer supported by Dynatrace. it is time for you to upgrade.

The error itself indicates that some configure files are missing - not sure how that happened

You might want to open a support ticket to also disucss the upgrade to a newer version of Dynatrace


Thank you Andreas. I understand that 6.1 is out of support, we are in the process to prepare upgrade. I got this issue since I applied the latest dynatrace 6.1 fixpack. not sure why dynatrace is looking for a non-existing file: server.jks. Sounds like keystore is broken. I have tried to follow the linke: however RESTful server is still not starting. I have opened the support ticket. they don't answer it any more. this issue impact our reporting of performance testing. so I am trying to see if any one has a way to solve this issue here.