cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

iam getting Agent connected issue taht is" Instrumentation was disabled during Agent runtime. The Collector runs on low memory"

sarath_koduru
Inactive

issue1.pngissue2.pngHi Team,


We are facing this issue with our collector which is deployed in Linux box"The Agent is connected, but Instrumentation was disabled during Agent runtime. The Collector runs on low memory."

Note - we use same server for collector and server.

please find attachments.

9 REPLIES 9

Babar_Qayyum
Leader

Hello Sarath,

The AppMon Collector uses by default 2 GB of memory. Depending on the number of Agents, you may need to adapt this default setting.

To change the amount of used memory, open the main configuration file (dtcollector.ini) in a text editor and adjust the values for the -Xmx and -Xmsparameters. Always use the same value for both parameters, and restart the AppMon Collector to apply your changes.

The following shows an example of an adapted dtcollector.ini, where memory usage was increased from the default 2 GB to 4 GB (see lines 6,7):

1    ...
2 -basedir
3 collector
4 -restartonfailure
5 -vmargs
6 -Xmx4G
7 -Xms4G
8 ...

Review the below collector best practices documentation.

https://www.dynatrace.com/support/doc/appmon/installation/deployment-guide/additional-deployment-bes...

Regards,

Babar

Hi @Babar,

Thanks for reply.after memory increase also we aregetting the same error.

Hello Sarath,

Do you have a firewall between agents and collector?

A firewall introduces latency in the calls between the Agent and Collector. This is often the reason for slow application start-up. The Agent needs to do several 10,000 round trips to the Collector at application start up. Even 1 ms firewall latency adds up to a noticeable time. Therefore, either use a real fast (in latency time) firewall or put the Collector into the same subnet as the Agents.

If you don't have a firewall in between then add the wait=30 (Specifies the initial wait timeout — the maximum time to wait for a connection to an AppMon Collector in seconds. If the connection cannot be established within this timeframe, the application continues uninstrumented) in the end of the arguments of those agents who are facing this issue.

Regards,

Babar

agent and collector both are in same subnet.we don't have a firewall in between those two.please tell me where i need to add that wait time. today i observe that out of 6,2 agents two is connected suceefully.remaing agents facing same connection issue.

PFA screen1.png

Hello Sarath,

Below is the example. Once modified the arguments then restart the application/process to connect to the collector.

-agentpath:/opt/apm/dynatrace-6.5/agent/lib64/libdtagent.so=name=XYZ,server=AA.BB.CC.DD:9998,wait=30

Regards,

Babar

JamesKitson
Dynatrace Leader
Dynatrace Leader

There's a total heap memory utilization for collectors in the dynatrace self monitoring profile. I would chart that to make sure your changes have been applied and that you are not still violating the threshold. If it is just the case that the error is still showing for those agents, you may need to restart them to restore instrumentation.

James

Hi James,

Thanks for Reply.now,i observed that heap memory utilization is 60% only.but some of the agents facing the same issue.

PFA.capture1.pngscreen1.png

Have you restarted the agents since the memory utilization has been down? If instrumentation is disabled at start up due to low memory you most likely need to restart the agents/application to restore it.

You'll also want to make sure the collector is stopped before making changes to dtcollector.ini, otherwise the changes may revert upon restart. You can view the .ini files in the system information dashlet in the client.