cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

This product reached the end of support date on March 31, 2021.

"Invalid password specified" for "Import and deploy certificate"

yuting_wu
Guide

I am trying to import my certificate and my keypair ( a PKCS #12 ) file using the wizard in "Certification Management" Tab under Server settings. However i am getting "Invalid password specified" error. I am using the same password for the keypair. Can anyone help here? Thank you in advance.




3 REPLIES 3

sebastian_kryst
DynaMight Leader
DynaMight Leader

Did you tried aCessna this certificate using different tool to check if indeed password is correct? From my experience, here everything should work as excepted.

Sebastian


The custom certificate requirements are found here: https://www.dynatrace.com/support/doc/appmon/installation/set-up-communication-connections/certifica...

FWIW, we used OPENSSL to convert our P7B(PKCS7) format certificate to PEM format, then bundled into a ZIP file along with the servers' private key and root cert (also in PEM format).

openssl pkcs7 -print_certs -in <yourp7bformatcert>.p7b -out <yourconvertedpemformatcert>.pem

I haven't tried the PKCS12 format import, but possibly you are not including the private key or root cert, or they are in PEM format?

bhupendra_raman
Newcomer

i found that if you used non apha-numeric chars in the password , AppMon does not recognise the password . Just use a plain simple password . I used a $ in my password and had the same issue.