cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to onboard ECS Fargate to Dynatrace using Run time injection method

ManasaM
Newcomer

Iam trying to onboard ECS services with Fargate launch type. Followed the Run time injection method as per the documentation. Also, defined  DT_LOGLEVELCON with the value INFO . In the logs, I don't see any specific error related to One agent deployment failure. But the FG Service doesn't  show up on Dynatrace. 
I have followed the same steps and was able to onboard ECS FG services from one of our cloud accounts, but unable to onboard the services from other accounts now. 

Attached cloudwatch logs and Task definition created with one agent run time injection method.

5 REPLIES 5

DanielS
DynaMight Leader
DynaMight Leader

I edited your post because you were publicly sharing your PaaS token.

The true delight is in the finding out rather than in the knowing.

DanielS
DynaMight Leader
DynaMight Leader

Hi @ManasaM. Please check if you are using Alpine images because you select in options flavor=musl&include=all

The true delight is in the finding out rather than in the knowing.

ManasaM
Newcomer

Hi Daniel. Thank you for your response. For the oneagent container image I've provided "alpine:3". Is there anything else that I'm missing?

DanielS
DynaMight Leader
DynaMight Leader

Assuming that you follow the procedure step by step, try to change this:

 

  • DT_ONEAGENT_OPTIONS- this is the flavor (valid options are default or musl for Alpine images) and the technology (code module).

    • Syntax for default is flavor=default&include=all.
    • Syntax for musl is flavor=musl&include=all.

Have in mind that your install-oneagent is alpine but may be others you are trying to set with OA are not.

You have set the musl in Options but maybe the Fargate containers are different.

 

The true delight is in the finding out rather than in the knowing.

ManasaM
Newcomer

Thanks for the suggestion. Initially DT_ONEAGENT_OPTIONS was set to flavor=musl&include=all and that worked without any issues for all services running node image alpine. The other services I was trying to onboard were not running on Debian Linux. And setting the DT_ONEAGENT_OPTIONS to flavor=default&include=all worked. 

Featured Posts