Showing results for 
Show  only  | Search instead for 
Did you mean: 

Notebook app was reverting my notebook name

I did want to note that I couldn't replicate this behavior at the time of creating this message but still wanted to call it out just in case others came across the same thing.

I got access to the new Dyntrace Preview a week back and am testing out the new Notebook app. I'm not sure if others are having issues with this or not but I was having a problem with the name of my notebook getting reverted. Earlier today I tried renaming it four different times and each time it reverted to "untitled" during the auto-save.

I tried again a few hours later to recreate it for this message though this time it appeared to work. The only thing I can think of that I did differently this time was allowing the auto-save to happen after I changed the name before moving on to other tasks rather than doing other work right after the name change. In other words, before, I would change the name and then go straight into adding panels with DQL statements. 

Travis Ottelien

Dynatrace Pro
Dynatrace Pro

Hi Travis,

Thank you very much for reporting this issue. We will have a closer look and do some investigation on our side.
Additionally, please let us know if you run into the same issue again or can reproduce it consistently.

Best, Philipp

Hi Philipp,

I was able to replicate it when I logged in to Dynatrace Preview this morning but after messing around with it for a while, it seemed to fix itself again and I can't replicate it. Though I did get a screenshot this time.  I got an error bar on top and when I clicked on it, it said "Error History: Error renaming document. HTTP Error 405: Method Not Allowed". 


I was able to replicate it two different ways though now it's again not erroring out. 

Method 1: Created a new notebook and named it something like "temp" and then created a panel.

Method 2: With a notebook successfully saved, I tried renaming it with an unfinished panel.


I was thinking since the panel wasn't quite finished it wouldn't allow the auto-save feature to work which, in turn, didn't allow the name change. However, now it's behaving when I run the same steps as above so I'm not so sure anymore. 


I hope this helps some though this behavior seems to be sporadic. 

Travis Ottelien

I'm seeing this error again. All I did was open a new workbook and tried to rename it right away. I then added some panels to see if that would help but it's still erroring out.



I'm also unable to rename a new dashboard I created so it doesn't seem specific just to Notebooks.


Travis Ottelien

Featured Posts