cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Issue in fetching logs through API

joshua_joseph
Newcomer

I have been trying to fetch logs using the /logs/aggregate, /logs/export and /logs/search and I'm getting the exact same error in search and export: 

 

 

{
   "error": {
      "code": 401,
      "message": "OAuth token is missing"
    }
}

 

 

and I'm getting this for /aggregate:

 

 

Error: response status is 501

Response headers
 cache-control: must-revalidate,no-cache,no-store 
 content-length: 0 
 pragma: no-cache 
 server: ruxit server 
 server-timing: dtRpid;desc="-554874041",dtSInfo;desc="0" 
 strict-transport-security: max-age=31536000;includeSubDomains 
 x-oneagent-js-injection: true 
 x-robots-tag: noindex 

 

 

the token I'm using has all the necessary scopes, and it works for every other api I've tested. I noticed that the 3 above apis have been marked as 'Early Adopter', is it being updated/changed right now?

I've also tried generating an oauth token and using that as a bearer token, but it simply returns an empty response, or fails 

for /search:

 

 

{
    "results": [],
    "sliceSize": 0,
    "nextSliceKey": null
}

 

 

 for /aggregate:

 

 

{
    "aggregationResult": {}
}

 

 

for /export

 

 

<html>

<head>
    <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1" />
    <title>Error 501 Not Implemented</title>
</head>

<body>
    <h2>HTTP ERROR 501 Not Implemented</h2>
    <table>
        <tr>
            <th>URI:</th>
            <td>/api/v2/logs/export</td>
        </tr>
        <tr>
            <th>STATUS:</th>
            <td>501</td>
        </tr>
        <tr>
            <th>MESSAGE:</th>
            <td>Not Implemented</td>
        </tr>
    </table>

</body>

</html>

 

 

if the endpoint in being changed, where can I see more info on it?

0 REPLIES 0

Featured Posts