cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

1.243.205 Agent Version not Retaining Network Zone Value

This is the 2nd time I have seen this, previously with an older version. We use BigFix to push out the agent upgrade for our hosts. When going from an older version to 1.243.205, the network zone value gets overridden and you end up with a value of 'default'.

 

Can we please address this. Why are we resetting the value here? The first time this happened I was not aware of it until after the upgrade, I had to reset the network zone on a few thousand hosts.

 

Maybe this issue does not occur with older versions, I don't know. I will say we've gone through another upgrade and the value remained what it was before. It seems to be a toss up whether or not the network zone value persists. It should ALWAYS persists.

4 REPLIES 4

AntonioSousa
DynaMight Guru
DynaMight Guru

How are you defining, or have defined, Network Zones? By the installation parameter or by oneagentctl?

One thing that comes to mind is that you might be defining it in a configuration file. Is that the case?

Antonio Sousa

We define ours at the install using '--set-network-zone='. We have issued this command after the fact to fix the previous time this happened. We don't touch any config files, we always set configs using the oneagentctl where possible.

@travis_anderson,

Given that you are setting the network zone on installation, I would say that this shouldn't happen. Probably better to open a ticket in Support, as Dynatrace will probably have to check & debug some specific issues in you environment/installation.

Antonio Sousa

Just wanted to clear this up. This seems to be a mistake on our part. I just now noticing that you can specify the network zone value for your install to use, when pulling it down. So in our curl command we had 'networkZone=default' for some reason, it should have never had this.

 

Seems to be no issue here, wanted to clear it up that it was on our end 🙂