cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Active Gate Installation issue

AK
Advisor

Hello Folks,

I would need some help in troubleshooting Active Gate installation which is failing due to following error,

Internet is not enabled on Active Gate server hence we allowed Dynatrace SaaS cluster IPs for communication between AG and Dynatrace on 443 port.

Has anyone encountered with same problem and resolved it successfully?

Regards,

AK

14 REPLIES 14

JamesKitson
Dynatrace Leader
Dynatrace Leader

What ActiveGate mode are you installing? Is it for synthetics?

sebastian_kryst
DynaMight Leader
DynaMight Leader

When you enable wget to download binary from SaaS to this ActiveGate server it works properly? (I'm asking in case of network issues). If it works than communication should work as well. Did you check installation logs of AG? Are there anything more?

Sebastian

Yes I was able to download installer via wget successfully. Here is the snippet of logs.

AG logs.txt

Did you try uninstallation of current AG and manual files removal from installation dir? After that try installation again with fresh binary downloaded via wget.

Sebastian

Yes I tried but no luck

Regards,

AK

Did you try to test with a curl against your tenant? You can try to reach your url

https://abc12345.live.dynatrace.com:443/communication

Also you can try PROXY parameter like descried on documentation


example:

./Dynatrace-ActiveGate-Linux-x86-1.175.274.sh PROXY=10.0.0.15:8080

Paco, thanks for your input but I would need more help here, from where do I get proxy details do I need to check with Network Team?

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello @Akshay S.

Following uninstallation, log files and part of the configuration are preserved in the ActiveGate installation directory. You'll have to remove these files manually and then restart the host/server before the new installation.

By default, ActiveGate is installed in the following directories on Windows and Linux:

  • On Windows: C:\Program Files\dynatrace\gateway
  • On Linux: /opt/dynatrace/gateway

The following link is for the customize AG installation.

https://www.dynatrace.com/support/help/setup-and-configuration/dynatrace-activegate/installation/cus...

Regards,

Babar

Hi Babar,

I tried already by removing the files manually and but no lock.

Is it possible that if one or more AG is already present in environment and during the installation of new AG, installer will try to communicate with other AGs may be just to check if any other AG is present in the environment or not?

I suspect, because we could see some IPs (In firewall logs) other than IPs present on Deploy Dynatrace --> Install ActiveGate --> Install Linux Environment ActiveGate page. IPs present on this page are already added onto the firewall exclusion.

Regards,

AK

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello @Akshay S.

ActiveGates are sorted with the following hierarchy:

  • Level # 1 Environment ActiveGate
  • Level # 2 Cluster ActiveGate
  • Level # 3 Embedded ActiveGate

Communication among ActiveGates: Environment ActiveGate > Cluster ActiveGate > Embedded ActiveGate

Deployment status will show you already installed Enivronement ActiveGates.

In the Cluster Management deployment status, you can see the Environment and Cluster ActiveGates together.

Regards,

Babar

Hi Babar,

We are using SaaS hence no cluster AG in here.

Correct me if I'm wrong, "If we keep installing AGs then they will distribute the load among themselves automatically". Will it be a case here that, new AG installer is checking presence of old or already installed AG for future load distribution?

Regards,

AK

Babar_Qayyum
DynaMight Leader
DynaMight Leader

Hello @Akshay S.

Exactly, they will distribute the load. You can verify the already installed Environment ActiveGate deployment status.

As I mentioned earlier the Environment ActiveGate talks to the Cluster ActiveGate on port 9999 (but you do not have the Cluster ActiveGate).

See the ports you need to open for your ActiveGates.

https://www.dynatrace.com/support/help/setup-and-configuration/dynatrace-activegate/configuration/wh...

If you are doing a customize ActiveGate installation, then have a look at the below link.

https://www.dynatrace.com/support/help/setup-and-configuration/dynatrace-activegate/installation/cus...

Regards,

Babar

AK
Advisor

Hi All,

Thanks for helping till here.

My issue is resolved. Support team helped to diagnose.

Installation was failing as one of the process on host was consuming 9999 port (AG's default port to accept incoming connections). We stopped the concern process, did the re-installation and it went successful.

Note:- Even if the communication from AG to Dynatrace SaaS tenant is successful on 443 port, it would be good to check if AG's incoming port 9999 (default) is occupied or not.

  • If occupied, we can stop that process permanently or restrict that process to use 9999 port.

OR

  • We can assigned different port to AG (other than 9999) through the custom.properties file. Link added below,

Configure ActiveGate

Regards,

AK