cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ActiveGate Server can telnet to Dynatrace SaaS, yet installation of ActiveGate failed with the message saying failed to connect to Dynatrace SaaS

Checkings done:

  • There is a certificate in-use and I did make sure that I supply the path to the certificate and also the password, during installation
  • ActiveGate installer of course I chmod it to become 777
  • ActiveGate installer isn't corrupted (downloaded it multiple times to try)
  • do telnet command multiple times, to make sure it can indeed connect to the different public IPs of the relevant SaaS tenant (command I use is telnet ccp76234.live.dynatrace.com 443)
  • supply the parameter DYNATRACE_ACTIVEGATE_SERVER_CONNECTION_TIMEOUT=240 during installation, nothing change either.


Checking log, it also said it failed to connect to ccp76234.live.dynatrace.com during installation, any idea what else I might try?


Best Regards,

Wai Keat

1 REPLY 1

Zbigniew_Wroble
Dynatrace Participant
Dynatrace Participant

Hi Wai,

Why do you need a certificate?

  • There is a certificate in-use and I did make sure that I supply the path to the certificate and also the password, during installation

I am asking because it suggests that you have a SSL termination proxy between the AG host and Dynatrace SaaS cluster. In other case, when you have a direct connection or a regular proxy, you do not need to configure the certificate during installation.

I suppose that you have checked the installer log file. Please check also /var/log/dynatrace/gateway/dynatracegateway.0.0.log or dynatracegateway_Debug.0.0.log, they are more talkative and may give you more hints.

Regards,

Zbigniew