cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ActiveGate with Proxy Installation Error

john_liebal1
Contributor

2018-09-19 13:52:31 UTC
SEVERE [<*******>] [MessageBroker] Failed to send
INITIAL_COLLECTOR_SETUP message (target-type=SERVER, target-id=-1000),
uri=https://******.live.dynatrace.com:443/communication -
CommunicationException: HTTP communication failed, status code=407,
reason=authenticationrequired

Command is:

sudo /bin/sh
Dynatrace-ActiveGate-Linux-x86-1.151.217.sh PROXY=********** USER=dynatrace INSTALL=/app TEMP=/app/tmp LOG=/app/logs/dynatrace
CONFIG=/app/conf/dynatrace/gateway

Is there something we are missing here?


6 REPLIES 6

JamesKitson
Dynatrace Leader
Dynatrace Leader

I bet that's your proxy asking for authentication:

https://www.dynatrace.com/support/help/deploy-dyna...

James


john_liebal1
Contributor

I thought that could be the case, the error does seem to indicate that the authentication is needed at Dynatrace.


alexander_schub
Newcomer

Hi We are facing a similar issue when installing Activegate-Linux with PROXY parameter. Our proxy does not require authentication. Any hints how to resolve the problem appreciated.

Thanks

Alex


teoderico_david
Participant

Has anyone successfully setup the Activegate-Linux with PROXY parameter? We are having the same issue? I appreciate if you can share how you resolved the issue.


Did you try to use the standard URL format for the proxy parameter? The https://username:password@proxy:port
Or export this variable prior to installation?

I think the gateway will install event without connectivity to cluster and you can specify the proxy parameters in config file afterwards.


TEMPEST a.s., Slovakia, Dynatrace Master Partner

teoderico_david
Participant

Julius, thanks for your respond. We are not using uid/pwd in our proxy and what we are trying to achieve is to do SSL Interception. I have set the URL, Port and Proxy-scheme to https. I have also imported the certificate to the custom keystore but we are getting SSL handshake error.