cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Agent Update - OneAgent installation failed on xxxx: Failed to elevate installer process privileges

jprio
Frequent Guest

Hello,

We have agent update problems on some hosts. We can see this on the installer logs : 

2022-01-25 10:57:25.895 UTC [b77f9860] info [native] AutoUpdater: Starting update to version 1.231.245.20220112-085307 from: "/var/lib/dynatrace/oneagent/agent/downloads/Dynatrace-OneAgent-Linux-1.231.245.20220112-085307.sh"
2022-01-25 10:57:25.895 UTC [b77f9860] info [native] AutoUpdater: Enough free space (2434 MiB) available on "/opt/dynatrace/oneagent", needed: 1642 MiB
2022-01-25 10:57:25.896 UTC [b77f9860] info [native] AutoUpdater: Free system memory: 3336 MB, required: 200 MB
2022-01-25 10:57:27.229 UTC [b77f9860] info [native] AutoUpdater: Used 184071490 bytes to calculate file sha-256 digest: ee94f81f558808be462dc534d7b8bdf26c916c5f0777494c858b83ecb8ec6235
2022-01-25 10:57:27.230 UTC [b77f9860] info [native] AutoUpdater: Signature verification successful
2022-01-25 10:57:27.230 UTC [b77f9860] info [native] AutoUpdater: Starting: "/var/lib/dynatrace/oneagent/agent/downloads/Dynatrace-OneAgent-Linux-1.231.245.20220112-085307.sh"
2022-01-25 10:57:27.232 UTC [b77f9860] warning [native] AutoUpdater: Setting ambient capabilities failed: Preparation for seting ambient capabilities failed: Failed to set capabilities: error code: 1, error message: Operation not permitted
2022-01-25 10:57:27.268 UTC [b77f9860] info [native] AutoUpdater: Process created successfully, pid: 11236
2022-01-25 10:57:27.268 UTC [b77f9860] severe [native] AutoUpdater: Installation failed: exited normally with code 200
2022-01-25 10:57:27.268 UTC [b77f9860] severe [native] AutoUpdater: Failed to elevate installer process privileges
2022-01-25 10:57:27.268 UTC [b77f9860] info [native] AutoUpdater: Increased delay between autoupdate attempts to 512 minutes.
2022-01-25 10:57:30.109 UTC [b67fb860] warning [native] ScopedCapability: Cannot add capability Capability::SYS_RESOURCE to effective set, it is not present in permitted set.

When running the installer as root, no problems.

Any idea ?

Best regards,

JP

2 REPLIES 2

ChadTurner
DynaMight Guru
DynaMight Guru

We had an issue like this where for some reason Linux was changing our permissions. It was hard to track down and I dont quite recall what it was. But the permission level would change randomly, I almost want to say it was security app converting the permission level. 

-Chad

mark_bley
Dynatrace Advisor
Dynatrace Advisor

Hi @jprio ,

this could mean some capabilities where removed from a OA binary or the folder structure/ownership changed. Please run a healthcheck to pinpoint files/folders causing a problem

 # /opt/dynatrace/oneagent/agent/tools/oneagentctl --healthcheck

In case of problems the healthcheck will try and recommend a way to remediate the problem, you may see something like this:

(info): [Test Name]: File Capabilities Test
(info): [ID]: 2
(info): [Status]: FAILED
(info): [Action Item]: Reinstall the agent to amend file capabilities and check for external interference.
(info): [Reason]: File capabilties are not set correctly.

Best,

Mark