cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Auto-Instrumentation iOS Mobile App

Hi,

I am supporting a PoC with the developers to instrument the Dynatrace OneAgent into iOS native apps

The developers had configured the require setting as document in the Dynatrace Help - cocoapods; also reference to youtube video https://www.youtube.com/watch?v=PV5IbndM54k; and verify with Dynatrace One that the setup was correct.

However, data is not showing on the application dashboard. Hope any kind soul could help the steps to troubleshoot.

Many Thanks


5 REPLIES 5

harp
Dynatrace Pro
Dynatrace Pro

Sorry with this little information it is hard to guess why no data is showing up.
• what is the configuration the customer used?
• what doe the iOS agent log say?
• which environment is this so we can take a look at it?

to not share all this stuff publically here I would recommend to open a Support Ticket


Ok sure, how do one access to iOS agent log and where does it located ? I will log a support case.


harp
Dynatrace Pro
Dynatrace Pro

Log is only available when run from Xcode - see Dynatrace Help for the required settings: https://www.dynatrace.com/support/help/deploy-dyn...

Did you follow the agent setup walkthroug after creating a mobile Application in the Dynatrace webUI?


Just want to update, the issue was resolve by the Dynatrace Presale who provision tenant.


Hi Patrick,

As I am not the developer, the developer did provide the necessary screenshots that had shown he had done the require steps accordingly based on Cocoapods instrumentation i.e adding the applicationId and etc extracted from Dynatrace SaaS webUi paste in the info.plist and also pod Dynatrace in pod file.

As mention, the developer did use the livechat to verify and livechat support didn't find anything not right in his configuration.

I had log a support case - https://support.dynatrace.com/supportportal/browse/SUP-15045