cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Certificate issue when configuring Cluster ActiveGate

alaaka
Visitor

Hi,

 

We are trying to configure Cluster ActiveGate to start monitoring workloads/applications on Azure and a mobile app. We configured things as per online documentation, and using a wildcard certificate. However when testing the connection to the public URL from CMC, we get result as per attachment (DT_CAG_2.png), while when attempting to access the mbeacon URL from a device on Internet, we get the "missing querystring" message as per attachment (DT_CAG_3.png). Even when we enable Dynatrace management of public domain name and certificates, we get same result. What are we missing here? Any specific log to check? How to confirm that CAG configuration is correct and ready to read monitoring data from cloud/mobile apps?

 

Thanks,

Alaa

2 REPLIES 2

alaaka
Visitor

Hi,

 

Appreciate sharing your advice please

 

Best Regards,

Radoslaw_Szulgo
Dynatrace Guru
Dynatrace Guru

hey @alaaka ,

I usually check the "health" endpoint from a "public location" like that:

 

$ curl -iS https://<cluster-ag-public-domain>:9999/rest/health

Where <cluster-ag-public-domain> is what you have set up in CMC -> Settings -> Cluster ActiveGate domain. 

The result should be as following:

HTTP/1.1 200 OK

Date: Mon, 31 Jan 2022 10:04:35 GMT

Server: ruxit security gateway

state: RUNNING

Content-Length: 8

RUNNING 

 

Note here especially:

-> HTTP Header "Server: ruxit security gateway" 

-> HTTP code 200 and payload "RUNNING"

Senior Product Manager,
Dynatrace Managed expert